aboutsummaryrefslogtreecommitdiff
path: root/tests2
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-19 16:41:46 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-19 16:41:46 +0000
commite6ab6834037b7dd737184a0e966836e770288a64 (patch)
treec3bc42f337cbf25ac7f5a946ebbdf3f4ef1104f4 /tests2
parentc32e453e9ee533f34ff179700f1c025bf2961dc4 (diff)
downloadContactsProvider-e6ab6834037b7dd737184a0e966836e770288a64.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Bug: 30188076 Test: make checkbuild Change-Id: I1275a0721d2f4598dcdc83e292c188ce36c37fc6
Diffstat (limited to 'tests2')
-rw-r--r--tests2/Android.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests2/Android.mk b/tests2/Android.mk
index c341f2cf..4209f0e6 100644
--- a/tests2/Android.mk
+++ b/tests2/Android.mk
@@ -22,7 +22,8 @@ LOCAL_MODULE_TAGS := tests
LOCAL_STATIC_JAVA_LIBRARIES := \
ContactsProviderTestUtils \
android-support-test \
- mockito-target-minus-junit4
+ mockito-target-minus-junit4 \
+ legacy-android-test
LOCAL_JAVA_LIBRARIES := android.test.runner