summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Baptiste Queru <jbq@google.com>2009-07-25 17:48:03 -0700
committerJean-Baptiste Queru <jbq@google.com>2009-07-25 17:48:03 -0700
commit9e8d5d68b38de5babbdb73c131a435677a1cc1e3 (patch)
treed7a498b23e8408247e3d6011af043fefa0d93210
parent0d63d1ebe512333a4e609e572debcff990308cf3 (diff)
parent51823c086b4af424aa0882315fe20deedc897a4e (diff)
downloadImProvider-9e8d5d68b38de5babbdb73c131a435677a1cc1e3.tar.gz
Merge korg/donut into korg/master
-rw-r--r--Android.mk3
-rw-r--r--res/values-de/strings.xml4
-rw-r--r--res/values-es-rUS/strings.xml36
-rw-r--r--res/values-ja/strings.xml4
-rw-r--r--res/values-pl/strings.xml10
-rw-r--r--res/values-zh-rTW/strings.xml2
-rw-r--r--tests/Android.mk10
-rw-r--r--tests/permission/Android.mk14
-rw-r--r--tests/permission/AndroidManifest.xml39
-rw-r--r--tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java53
10 files changed, 165 insertions, 10 deletions
diff --git a/Android.mk b/Android.mk
index 4c2023a..cc4b7f0 100644
--- a/Android.mk
+++ b/Android.mk
@@ -14,3 +14,6 @@ LOCAL_PACKAGE_NAME := ImProvider
LOCAL_CERTIFICATE := shared
include $(BUILD_PACKAGE)
+
+# additionally, build sub-tests in a separate .apk
+include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
diff --git a/res/values-de/strings.xml b/res/values-de/strings.xml
index 04614f7..b162c34 100644
--- a/res/values-de/strings.xml
+++ b/res/values-de/strings.xml
@@ -15,9 +15,9 @@
-->
<resources xmlns:android="http://schemas.android.com/apk/res/android"
xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="ro_perm_label">"Chat-Nachrichten lesen"</string>
+ <string name="ro_perm_label">"Instant Messages lesen"</string>
<string name="ro_perm_desc">"Ermöglicht Anwendungen das Lesen von Daten des IM-Content-Providers."</string>
- <string name="wo_perm_label">"Chat-Nachrichten verfassen"</string>
+ <string name="wo_perm_label">"Instant Messages verfassen"</string>
<string name="wo_perm_desc">"Ermöglicht Anwendungen das Schreiben von Daten an den IM-Content-Provider."</string>
<string name="im_label">"IM"</string>
<string name="landing_page_title">"Chat - Konto auswählen"</string>
diff --git a/res/values-es-rUS/strings.xml b/res/values-es-rUS/strings.xml
new file mode 100644
index 0000000..fa272a6
--- /dev/null
+++ b/res/values-es-rUS/strings.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright (C) 2009 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+<resources xmlns:android="http://schemas.android.com/apk/res/android"
+ xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
+ <string name="ro_perm_label">"leer mensajes instantáneos"</string>
+ <string name="ro_perm_desc">"Permite a una aplicación leer datos del proveedor de contenido de mensajería instantánea"</string>
+ <string name="wo_perm_label">"escribir mensajes instantáneos"</string>
+ <string name="wo_perm_desc">"Permite a una aplicación introducir datos en el proveedor de contenido de mensajería instantánea"</string>
+ <string name="im_label">"Mensajería instantánea"</string>
+ <string name="landing_page_title">"Chat - Seleccionar una cuenta"</string>
+ <string name="menu_add_account">"Agregar cuenta"</string>
+ <string name="menu_edit_account">"Editar cuenta"</string>
+ <string name="menu_remove_account">"Suprimir cuenta"</string>
+ <string name="sign_in">"Inicia sesión"</string>
+ <string name="menu_sign_out">"Cerrar sesión"</string>
+ <string name="menu_settings">"Configuración"</string>
+ <string name="menu_sign_out_all">"Cerrar sesión de todo"</string>
+ <string name="choose_account_title">"Chat - Seleccionar una cuenta"</string>
+ <string name="conversations">"(%1$d)"</string>
+ <string name="add_account">"Agregar cuenta <xliff:g id="ACCOUNT">%1$s</xliff:g>"</string>
+ <string name="menu_view_contact_list">"Lista de contactos"</string>
+ <string name="signing_in_wait">"Iniciando sesión..."</string>
+</resources>
diff --git a/res/values-ja/strings.xml b/res/values-ja/strings.xml
index 6f9a4ae..993dc42 100644
--- a/res/values-ja/strings.xml
+++ b/res/values-ja/strings.xml
@@ -16,9 +16,9 @@
<resources xmlns:android="http://schemas.android.com/apk/res/android"
xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
<string name="ro_perm_label">"インスタントメッセージを表示"</string>
- <string name="ro_perm_desc">"IMコンテンツプロバイダーからのデータ読み取りをアプリケーションに許可します。"</string>
+ <string name="ro_perm_desc">"アプリケーションでIMコンテンツプロバイダからデータを読み取れるようにします。"</string>
<string name="wo_perm_label">"インスタントメッセージを作成"</string>
- <string name="wo_perm_desc">"IMコンテンツプロバイダーからのデータ書き込みをアプリケーションに許可します。"</string>
+ <string name="wo_perm_desc">"アプリケーションからIMコンテンツプロバイダにデータを書き込めるようにします。"</string>
<string name="im_label">"チャット"</string>
<string name="landing_page_title">"チャット: アカウントを選択"</string>
<string name="menu_add_account">"アカウントを追加"</string>
diff --git a/res/values-pl/strings.xml b/res/values-pl/strings.xml
index 150bbbe..c2154ba 100644
--- a/res/values-pl/strings.xml
+++ b/res/values-pl/strings.xml
@@ -15,11 +15,11 @@
-->
<resources xmlns:android="http://schemas.android.com/apk/res/android"
xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="ro_perm_label">"odczytaj wiadomości czatu"</string>
- <string name="ro_perm_desc">"Zezwala aplikacjom na odczytywanie danych od dostawcy zawartości czatu."</string>
- <string name="wo_perm_label">"zapisz wiadomości czatu"</string>
- <string name="wo_perm_desc">"Zezwala aplikacjom na zapisywanie danych do dostawcy zawartości czatu."</string>
- <string name="im_label">"Czat"</string>
+ <string name="ro_perm_label">"odczytaj wiadomości komunikatora"</string>
+ <string name="ro_perm_desc">"Zezwalaj aplikacjom na odczytywanie danych dostawcy zawartości komunikatora"</string>
+ <string name="wo_perm_label">"zapisz wiadomości komunikatora"</string>
+ <string name="wo_perm_desc">"Zezwalaj aplikacjom na zapisywanie danych do dostawcy zawartości komunikatora"</string>
+ <string name="im_label">"Komunikator"</string>
<string name="landing_page_title">"Czat: Wybierz konto"</string>
<string name="menu_add_account">"Dodaj konto"</string>
<string name="menu_edit_account">"Edytuj konto"</string>
diff --git a/res/values-zh-rTW/strings.xml b/res/values-zh-rTW/strings.xml
index 0b3a949..7eed19a 100644
--- a/res/values-zh-rTW/strings.xml
+++ b/res/values-zh-rTW/strings.xml
@@ -31,6 +31,6 @@
<string name="choose_account_title">"即時通訊 - 選取帳戶"</string>
<string name="conversations">"(%1$d)"</string>
<string name="add_account">"新增 <xliff:g id="ACCOUNT">%1$s</xliff:g> 帳戶"</string>
- <string name="menu_view_contact_list">"通訊錄"</string>
+ <string name="menu_view_contact_list">"聯絡人"</string>
<string name="signing_in_wait">"登入中…"</string>
</resources>
diff --git a/tests/Android.mk b/tests/Android.mk
new file mode 100644
index 0000000..e9e3a87
--- /dev/null
+++ b/tests/Android.mk
@@ -0,0 +1,10 @@
+LOCAL_PATH:= $(call my-dir)
+
+########################
+
+include $(CLEAR_VARS)
+
+# no tests to build for now
+
+# additionally, build sub-tests in a separate .apk
+include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
diff --git a/tests/permission/Android.mk b/tests/permission/Android.mk
new file mode 100644
index 0000000..554ad62
--- /dev/null
+++ b/tests/permission/Android.mk
@@ -0,0 +1,14 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+# We only want this apk build for tests.
+LOCAL_MODULE_TAGS := tests
+
+# Include all test java files.
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_JAVA_LIBRARIES := android.test.runner
+LOCAL_PACKAGE_NAME := ImProviderPermissionTests
+
+include $(BUILD_PACKAGE)
+
diff --git a/tests/permission/AndroidManifest.xml b/tests/permission/AndroidManifest.xml
new file mode 100644
index 0000000..fe83af1
--- /dev/null
+++ b/tests/permission/AndroidManifest.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+ * Copyright (C) 2009 Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ -->
+
+<manifest xmlns:android="http://schemas.android.com/apk/res/android"
+ package="com.android.providers.im.permission.tests">
+
+ <application>
+ <uses-library android:name="android.test.runner" />
+ </application>
+
+ <!--
+ The tests in this package are intended to verify that protected APIs or data
+ cannot be accessed without the necessary permissions. Thus this manifest should not
+ include any uses-permissions tags
+ -->
+
+ <!--
+ The test declared in this instrumentation can be run via this command
+ "adb shell am instrument -w com.android.providers.im.permission.tests/android.test.InstrumentationTestRunner"
+ -->
+ <instrumentation android:name="android.test.InstrumentationTestRunner"
+ android:targetPackage="com.android.providers.im.permission.tests"
+ android:label="Tests for IM provider permissions"/>
+
+</manifest>
diff --git a/tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java b/tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java
new file mode 100644
index 0000000..0f2f0ae
--- /dev/null
+++ b/tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java
@@ -0,0 +1,53 @@
+/*
+ * Copyright (C) 2009 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.providers.im.permission.tests;
+
+import java.io.IOException;
+
+import android.net.Uri;
+import android.test.AndroidTestCase;
+import android.test.suitebuilder.annotation.MediumTest;
+
+/**
+ * Verify that protected Im provider actions require specific permissions.
+ */
+public class ImProviderPermissionsTest extends AndroidTestCase {
+
+ private static final String CONTENT_IM = "content://im";
+
+ /**
+ * Test that an untrusted app cannot read from the im provider
+ * <p>Tests Permission:
+ * {@link com.android.providers.im.Manifest.permission#READ_ONLY}
+ */
+ @MediumTest
+ public void testReadImProvider() throws Exception {
+ assertReadingContentUriRequiresPermission(Uri.parse(CONTENT_IM),
+ "com.android.providers.im.permission.READ_ONLY");
+ }
+
+ /**
+ * Test that an untrusted app cannot write to the download provider
+ * <p>Tests Permission:
+ * {@link com.android.providers.downloads.Manifest.permission#ACCESS_DOWNLOAD_MANAGER}
+ */
+ @MediumTest
+ public void testWriteImProvider() throws IOException {
+ assertWritingContentUriRequiresPermission(Uri.parse(CONTENT_IM),
+ "com.android.providers.im.permission.WRITE_ONLY");
+ }
+}