summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Chabot <brettchabot@google.com>2009-07-16 17:54:37 -0700
committerAndroid Git Automerger <android-git-automerger@android.com>2009-07-16 17:54:37 -0700
commit1f78052e52f7bdbf9a314b8d826979d9e871cf49 (patch)
tree06e7bf886adc5205f7408fccd27ff320bb9d32f3
parent64fec6ebd62a3627164858141172debf431c9b4e (diff)
parent9d6f85f0aa19d210cec631b55428ee3b2b9b1036 (diff)
downloadImProvider-1f78052e52f7bdbf9a314b8d826979d9e871cf49.tar.gz
am 9d6f85f0: Fix ImProvider makefile so tests source are not included when building Improvider package.
Merge commit '9d6f85f0aa19d210cec631b55428ee3b2b9b1036' * commit '9d6f85f0aa19d210cec631b55428ee3b2b9b1036': Fix ImProvider makefile so tests source are not included when building Improvider package.
-rw-r--r--Android.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index cc4b7f0..f7f22cc 100644
--- a/Android.mk
+++ b/Android.mk
@@ -3,7 +3,7 @@ include $(CLEAR_VARS)
LOCAL_MODULE_TAGS := user
-LOCAL_SRC_FILES := $(call all-subdir-java-files)
+LOCAL_SRC_FILES := $(call all-java-files-under,src)
LOCAL_JAVA_LIBRARIES := ext \
com.android.im.plugin # TODO: remove this and load this on demand.
@@ -16,4 +16,4 @@ LOCAL_CERTIFICATE := shared
include $(BUILD_PACKAGE)
# additionally, build sub-tests in a separate .apk
-include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
+include $(call all-makefiles-under,$(LOCAL_PATH))