summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 18:31:39 +0000
committerAnton Hansson <hansson@google.com>2018-02-23 10:35:33 +0000
commitfbfc5ef9373b3d12bf02d06e24ca49fc8577f59a (patch)
tree72b5e02633c3fc4f70c4c682dc85a033fbf4a571
parentef814aa2329f69d83af0e22bf0c542448e4feac1 (diff)
downloadPartnerBookmarksProvider-fbfc5ef9373b3d12bf02d06e24ca49fc8577f59a.tar.gz
packages/providers/PartnerBookmarksProvider: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I7ba748f11eb087357c31185ed256323696e6468b
-rw-r--r--Android.mk1
-rw-r--r--tests/Android.mk3
2 files changed, 3 insertions, 1 deletions
diff --git a/Android.mk b/Android.mk
index be94d89..b85a651 100644
--- a/Android.mk
+++ b/Android.mk
@@ -23,6 +23,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := android-common
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := PartnerBookmarksProvider
+LOCAL_SDK_VERSION := current
LOCAL_PROGUARD_FLAG_FILES := proguard.flags
include $(BUILD_PACKAGE)
diff --git a/tests/Android.mk b/tests/Android.mk
index 020aad8..8a107c7 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -23,8 +23,9 @@ LOCAL_MODULE_TAGS := tests
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := PartnerBookmarksProviderTest
+LOCAL_SDK_VERSION := current
-LOCAL_JAVA_LIBRARIES := ext android.test.base
+LOCAL_JAVA_LIBRARIES := android.test.base.stubs
LOCAL_STATIC_JAVA_LIBRARIES := junit
LOCAL_INSTRUMENTATION_FOR := PartnerBookmarksProvider