summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-12-05 18:36:57 +0000
committerPaul Duffin <paulduffin@google.com>2017-12-05 18:36:57 +0000
commit394c62c34ef02f20ab8ec2a98db18a9290bbcdd2 (patch)
treeb331fe5a0b675f5a18e0fe20b620a9d7d668f4b2
parentfd2b16a0ebcee4b0810c8051b2cd22cfa99f8ba0 (diff)
downloadPartnerBookmarksProvider-394c62c34ef02f20ab8ec2a98db18a9290bbcdd2.tar.gz
Flatten dependency hierarchy of legacy-android-test
Previous changes statically included legacy-android-test in preparation for removing android.test.* and junit.* classes from the android.jar. Unfortunately, that lead to duplicate classes between APKs and the bootclasspath which caused build problems (Proguard) and also runtime problems (when targeting and running on older releases). Switching from statically including the classes to using the runtime libraries cannot be done in one step because legacy-android-test is statically included in libraries which are used in many APKs and so removing it from those libraries requires that all APKs be updated at once. Doing that atomically across dozens of projects is not practical. This change modifies APKS that statically include the legacy-android-test library indirectly. * If the APK manifest uses the android.test.runner library then the APK is modified to stop statically including legacy-android-test and instead build against android.test.base/mock/runner libraries instead. * Otherwise, the APK statically includes legacy-android-test. Also, any libraries that statically include are modified to stop statically including it and if it has source dependencies on the classes is changed to build against the android.test.base/mock/runner libraries. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * tests/Android.mk Replaced 'legacy-android-test' with 'android.test.base' in LOCAL_JAVA_LIBRARIES because PartnerBookmarksProviderTest's source depends on its classes. The classes do not need to be statically included because the classes will be provided by the runtime, either from the default bootclasspath or from the android.test.runner library that PartnerBookmarksProviderTest specifies in its manifest. Bug: 30188076 Test: make checkbuild Change-Id: I855a718870bdad9897830036577765c01b3db77d
-rw-r--r--tests/Android.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index b509e96..020aad8 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -24,7 +24,7 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := PartnerBookmarksProviderTest
-LOCAL_JAVA_LIBRARIES := ext legacy-android-test
+LOCAL_JAVA_LIBRARIES := ext android.test.base
LOCAL_STATIC_JAVA_LIBRARIES := junit
LOCAL_INSTRUMENTATION_FOR := PartnerBookmarksProvider