summaryrefslogtreecommitdiff
path: root/tests/Android.mk
diff options
context:
space:
mode:
authorRuslan Abdikeev <aruslan@google.com>2012-05-14 08:14:11 -0700
committerRuslan Abdikeev <aruslan@google.com>2012-05-14 08:14:11 -0700
commit60c131771453fcb65e03ae77f8a378bfa48e6498 (patch)
tree4603f6b3bd3f3afb731368b727f8e34f270d8568 /tests/Android.mk
parent6b04cb56970c528aaf379a64c1492af01ce9ef7e (diff)
downloadPartnerBookmarksProvider-60c131771453fcb65e03ae77f8a378bfa48e6498.tar.gz
Default implementation of PartnerBookmarksProvider
A “Default” Partner Bookmark content provider implements the Partner Bookmarks Content Provider API, and uses xml and raw resources to extract the set of bookmarks and corresponding icons. Bug: 6399404 Change-Id: I416e87320b2ba958aa4f260277e4d6de20856c48
Diffstat (limited to 'tests/Android.mk')
-rw-r--r--tests/Android.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
new file mode 100644
index 0000000..7177397
--- /dev/null
+++ b/tests/Android.mk
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2012 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+# We only want this apk build for tests.
+LOCAL_MODULE_TAGS := tests
+
+# Include all test java files.
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_PACKAGE_NAME := PartnerBookmarksProviderTest
+
+LOCAL_JAVA_LIBRARIES := ext android.test.runner
+
+LOCAL_INSTRUMENTATION_FOR := PartnerBookmarksProvider
+
+include $(BUILD_PACKAGE)