summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongwon Kang <dwkang@google.com>2017-03-30 17:08:49 +0000
committerandroid-build-merger <android-build-merger@google.com>2017-03-30 17:08:49 +0000
commite07dbb0eddeec6206a890adbb6946e04d805c2db (patch)
tree24d552e6ad24bf94c358978fb8751a6530491ae5
parent36e645f5707c5ab5b3f32af67702622379a7cdbe (diff)
parent8ade928b05989f93295533da27c549756516dc44 (diff)
downloadTvProvider-e07dbb0eddeec6206a890adbb6946e04d805c2db.tar.gz
Make TvProvider a system app to send protected-broadcasts am: d67e9bd5d5
am: 8ade928b05 Change-Id: I64cd693249b7a55db0d18171def79d819bf86c55
-rw-r--r--Android.mk2
-rw-r--r--AndroidManifest.xml5
2 files changed, 5 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index 6cb2e03..a56d4ec 100644
--- a/Android.mk
+++ b/Android.mk
@@ -20,6 +20,8 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-java-files-under, src)
+LOCAL_CERTIFICATE := platform
+
LOCAL_PACKAGE_NAME := TvProvider
LOCAL_PRIVILEGED_MODULE := true
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 6eae819..0ea2596 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -15,7 +15,8 @@
limitations under the License.
-->
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
- package="com.android.providers.tv" >
+ package="com.android.providers.tv"
+ android:sharedUserId="android.uid.system">
<!-- Allows an application to read (but not write) all the TV listings.
This is the only (soon-to-be) public permission among other permissions defined here.
@@ -97,4 +98,4 @@
</intent-filter>
</receiver>
</application>
-</manifest> \ No newline at end of file
+</manifest>