summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 18:07:40 +0000
committerAnton Hansson <hansson@google.com>2018-02-23 17:01:59 +0000
commite35e45f6bae752bed101f165be9d19af89e3c2ec (patch)
tree47c710a929244cfd5dd7d72336b1c55a4f3a40af
parentcdc230cb065ec3c8f4659189b28a4803254712cd (diff)
downloadTvProvider-e35e45f6bae752bed101f165be9d19af89e3c2ec.tar.gz
packages/providers/TvProvider: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: Id1a9d74938633527cda8ca9cd24bb83161661953
-rw-r--r--Android.mk1
-rw-r--r--tests/Android.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 6cb2e03..588aa49 100644
--- a/Android.mk
+++ b/Android.mk
@@ -21,6 +21,7 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := TvProvider
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_PRIVILEGED_MODULE := true
include $(BUILD_PACKAGE)
diff --git a/tests/Android.mk b/tests/Android.mk
index 1c1478e..3c415e6 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -21,6 +21,7 @@ LOCAL_MODULE_TAGS := tests
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := TvProviderTests
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_JAVA_LIBRARIES := android.test.runner android.test.base android.test.mock
LOCAL_STATIC_JAVA_LIBRARIES := junit
LOCAL_INSTRUMENTATION_FOR := TvProvider