summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 18:07:41 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 18:07:41 +0000
commitd6c39576b87b984f827bb816c380650cae564509 (patch)
tree185023da12df541e1e744524407bbd1f2f19d450
parent6c7096864b97843e0aaccdf3f1e947ab8eb0af99 (diff)
downloadUserDictionaryProvider-d6c39576b87b984f827bb816c380650cae564509.tar.gz
packages/providers/UserDictionaryProvider: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I7808852a31dad2b5c4c51e8c4de1eda24f1b5004
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 5c33c33..d9b5907 100644
--- a/Android.mk
+++ b/Android.mk
@@ -8,6 +8,7 @@ LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_JAVA_LIBRARIES := ext
LOCAL_PACKAGE_NAME := UserDictionaryProvider
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_CERTIFICATE := shared
LOCAL_PROGUARD_FLAG_FILES := proguard.flags