aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Pawlowski <jpawlowski@google.com>2017-08-08 07:48:36 -0700
committerJakub Pawlowski <jpawlowski@google.com>2017-08-09 14:47:02 -0700
commit3c6e344ebf379c2a660b2e66bb87a0f1b7ae548f (patch)
tree93f514c865b868c6246166b87c30380c054fd278
parent18e2f6946a5374dd4e40277265cc8ee6a9f5dbfe (diff)
downloadCar-3c6e344ebf379c2a660b2e66bb87a0f1b7ae548f.tar.gz
Bluetooth: move AIDL files related to bluetooth into system/bt (3/3)
This patch moves *.aidl files from frameworks/base/core/java/android/bluetooth into system/bt/binder. This is in preparation to convert the Bluetooth deamon into native implementation piece by piece. In order to do that, one must have C++ header files, and paths to them with AIDL files, and */java/* folder didn't seem as proper place for that. Additionally, keeping AIDL files out of framework/base will not require creating dependency on this huge project, which should help keeping the compilation fast. Test: compilation test Change-Id: I75b898380bd0a2f22a8495d8e10156f1efa64495
-rw-r--r--car-lib/Android.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/car-lib/Android.mk b/car-lib/Android.mk
index a07e940376..53be4a761b 100644
--- a/car-lib/Android.mk
+++ b/car-lib/Android.mk
@@ -37,6 +37,7 @@ else
car_lib_sources += $(call all-java-files-under, src_feature_current)
endif
car_lib_sources += $(call all-Iaidl-files-under, src)
+LOCAL_AIDL_INCLUDES += system/bt/binder
LOCAL_SRC_FILES := $(car_lib_sources)
@@ -65,6 +66,7 @@ include $(CLEAR_VARS)
LOCAL_MODULE := android.car7
LOCAL_SRC_FILES := $(car_lib_sources)
LOCAL_JAVA_LANGUAGE_VERSION := 1.7
+LOCAL_AIDL_INCLUDES += system/bt/binder
ifeq ($(EMMA_INSTRUMENT_FRAMEWORK),true)
LOCAL_EMMA_INSTRUMENT := true