aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Moreland <smoreland@google.com>2017-08-02 20:14:39 +0000
committerandroid-build-merger <android-build-merger@google.com>2017-08-02 20:14:39 +0000
commit8d62530216422ea1de8738a6cc86dcb3c2cabee0 (patch)
tree8c8ddb565284bfbc76c19e4373b192c0ea52a0c6
parent2dc7251c245e1ed434f11e4e9b3d1467a71ffddb (diff)
parent79295cd9a274ae909c681a36b72961e24dd6c614 (diff)
downloadCar-8d62530216422ea1de8738a6cc86dcb3c2cabee0.tar.gz
Car: remove use of -static hidl java am: be4780ccce am: 8b9969b76e
am: 79295cd9a2 Change-Id: I090acbee7f97d2aacdaa578182b88d0796b6f6a9
-rw-r--r--service/Android.mk8
-rw-r--r--tests/EmbeddedKitchenSinkApp/Android.mk2
-rw-r--r--tests/android_car_api_test/Android.mk2
-rw-r--r--tests/vehiclehal_test/Android.mk4
-rw-r--r--vehicle-hal-support-lib/Android.mk4
5 files changed, 10 insertions, 10 deletions
diff --git a/service/Android.mk b/service/Android.mk
index 46bb9da1b5..0192823e2d 100644
--- a/service/Android.mk
+++ b/service/Android.mk
@@ -38,8 +38,8 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_JAVA_LIBRARIES += android.car
LOCAL_STATIC_JAVA_LIBRARIES += \
- android.hardware.automotive.vehicle-V2.0-java-static \
- android.hardware.automotive.vehicle-V2.1-java-static \
+ android.hardware.automotive.vehicle-V2.0-java \
+ android.hardware.automotive.vehicle-V2.1-java \
vehicle-hal-support-lib \
car-systemtest \
@@ -57,8 +57,8 @@ LOCAL_MODULE := car-service-lib-for-test
LOCAL_JAVA_LIBRARIES += android.car
LOCAL_STATIC_JAVA_LIBRARIES += \
- android.hardware.automotive.vehicle-V2.0-java-static \
- android.hardware.automotive.vehicle-V2.1-java-static \
+ android.hardware.automotive.vehicle-V2.0-java \
+ android.hardware.automotive.vehicle-V2.1-java \
vehicle-hal-support-lib \
car-systemtest \
diff --git a/tests/EmbeddedKitchenSinkApp/Android.mk b/tests/EmbeddedKitchenSinkApp/Android.mk
index d6619022ed..c8ece9f0c0 100644
--- a/tests/EmbeddedKitchenSinkApp/Android.mk
+++ b/tests/EmbeddedKitchenSinkApp/Android.mk
@@ -40,7 +40,7 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_DEX_PREOPT := false
LOCAL_STATIC_JAVA_LIBRARIES += \
- android.hardware.automotive.vehicle-V2.0-java-static \
+ android.hardware.automotive.vehicle-V2.0-java \
vehicle-hal-support-lib \
car-service-lib-for-test \
diff --git a/tests/android_car_api_test/Android.mk b/tests/android_car_api_test/Android.mk
index 306a240f51..0e47bb652d 100644
--- a/tests/android_car_api_test/Android.mk
+++ b/tests/android_car_api_test/Android.mk
@@ -35,7 +35,7 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES := junit legacy-android-test
LOCAL_STATIC_JAVA_LIBRARIES += \
android-support-test \
- android.hardware.automotive.vehicle-V2.0-java-static \
+ android.hardware.automotive.vehicle-V2.0-java \
LOCAL_JAVA_LIBRARIES := android.car android.test.runner
diff --git a/tests/vehiclehal_test/Android.mk b/tests/vehiclehal_test/Android.mk
index 43aa41f484..2c85c653c3 100644
--- a/tests/vehiclehal_test/Android.mk
+++ b/tests/vehiclehal_test/Android.mk
@@ -33,8 +33,8 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES += vehicle-hal-support-lib \
android-support-test \
- android.hardware.automotive.vehicle-V2.0-java-static \
- android.hardware.automotive.vehicle-V2.1-java-static
+ android.hardware.automotive.vehicle-V2.0-java \
+ android.hardware.automotive.vehicle-V2.1-java
LOCAL_JAVA_LIBRARIES := android.car android.test.runner
diff --git a/vehicle-hal-support-lib/Android.mk b/vehicle-hal-support-lib/Android.mk
index 638e5cf26e..688fb24778 100644
--- a/vehicle-hal-support-lib/Android.mk
+++ b/vehicle-hal-support-lib/Android.mk
@@ -24,8 +24,8 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_STATIC_JAVA_LIBRARIES := \
- android.hardware.automotive.vehicle-V2.0-java-static \
- android.hardware.automotive.vehicle-V2.1-java-static \
+ android.hardware.automotive.vehicle-V2.0-java \
+ android.hardware.automotive.vehicle-V2.1-java \
junit \
legacy-android-test