aboutsummaryrefslogtreecommitdiff
path: root/car-lib/src/android/car/CarManagerBase.java
diff options
context:
space:
mode:
authorKeun-young Park <keunyoung@google.com>2016-02-16 19:02:18 -0800
committerKeun-young Park <keunyoung@google.com>2016-02-18 13:42:01 -0800
commite54ac276796c6535558f8444d882adecd19ce2bd (patch)
treecb5c90914ea96a1455a356484620df10642f19b6 /car-lib/src/android/car/CarManagerBase.java
parent7dba5cfdc33d80b592ae3d3f1dc1ac4e10f13330 (diff)
downloadCar-e54ac276796c6535558f8444d882adecd19ce2bd.tar.gz
add android.car
- instead of using binder as compatibility layer, add android.car - apps using android.car should add it to LOCAL_JAVA_LIBRARIES unless doing include packages/services/Car/car-support-lib/car-support.mk - support lib renamed to android.support.car - UI stuffs only exist in android.support.car UI has dependency on androud support library and not added to android.car - permission only uses android.car namespace even for support.car - car-systemtest remains as static library. To use CarTestManager, test app should get CarTestManagerBinderWrapper then create CarTestManager. bug: 27199752 Change-Id: I3522e11e958dade404443fbe2d45f576c827fa7a
Diffstat (limited to 'car-lib/src/android/car/CarManagerBase.java')
-rw-r--r--car-lib/src/android/car/CarManagerBase.java25
1 files changed, 25 insertions, 0 deletions
diff --git a/car-lib/src/android/car/CarManagerBase.java b/car-lib/src/android/car/CarManagerBase.java
new file mode 100644
index 0000000000..737f356798
--- /dev/null
+++ b/car-lib/src/android/car/CarManagerBase.java
@@ -0,0 +1,25 @@
+/*
+ * Copyright (C) 2015 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package android.car;
+
+/**
+ * Common interface for Car*Manager
+ * @hide
+ */
+public interface CarManagerBase {
+ void onCarDisconnected();
+}