aboutsummaryrefslogtreecommitdiff
path: root/evs/sampleDriver/Android.mk
diff options
context:
space:
mode:
authorScott Randolph <randolphs@google.com>2017-04-25 17:38:29 -0700
committerScott Randolph <randolphs@google.com>2017-05-02 16:47:36 -0700
commitb342cb163393317d8af77339ff8ff5e921bd4a8f (patch)
treeb5807ef0bbe3d37db0b7337dd267707abc5c6b3f /evs/sampleDriver/Android.mk
parentfd519152b4ca81a8635c3c94c8c1c4e5d0021719 (diff)
downloadCar-b342cb163393317d8af77339ff8ff5e921bd4a8f.tar.gz
V4L2 & Surface Flinger based EVS driver
This provides a functional driver, although not suitable for use at early boot because of the SurfaceFlinger dependency. This is enough to get a demo application running, however, and to illustrate the necessary behaviors. Test: Build and run against evs_app Change-Id: I5492a7818018319bdf7e00f147d387e14acf4993
Diffstat (limited to 'evs/sampleDriver/Android.mk')
-rw-r--r--evs/sampleDriver/Android.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/evs/sampleDriver/Android.mk b/evs/sampleDriver/Android.mk
new file mode 100644
index 0000000000..840c239ecf
--- /dev/null
+++ b/evs/sampleDriver/Android.mk
@@ -0,0 +1,43 @@
+LOCAL_PATH:= $(call my-dir)
+
+##################################
+include $(CLEAR_VARS)
+
+LOCAL_SRC_FILES := \
+ service.cpp \
+ EvsEnumerator.cpp \
+ EvsV4lCamera.cpp \
+ EvsGlDisplay.cpp \
+ GlWrapper.cpp \
+ VideoCapture.cpp \
+ bufferCopy.cpp \
+
+
+LOCAL_SHARED_LIBRARIES := \
+ android.hardware.automotive.evs@1.0 \
+ libui \
+ libgui \
+ libEGL \
+ libGLESv2 \
+ libbase \
+ libbinder \
+ libcutils \
+ libhardware \
+ libhidlbase \
+ libhidltransport \
+ liblog \
+ libutils \
+
+
+LOCAL_MODULE := android.hardware.automotive.evs@1.0-sample
+
+LOCAL_MODULE_TAGS := optional
+LOCAL_STRIP_MODULE := keep_symbols
+
+LOCAL_CFLAGS += -DGL_GLEXT_PROTOTYPES -DEGL_EGLEXT_PROTOTYPES
+LOCAL_CFLAGS += -Wall -Werror -Wunused -Wunreachable-code
+
+# NOTE: It can be helpful, while debugging, to disable optimizations
+#LOCAL_CFLAGS += -O0 -g
+
+include $(BUILD_EXECUTABLE)