aboutsummaryrefslogtreecommitdiff
path: root/tests/UxRestrictionsSample
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-23 15:50:29 +0000
committerAnton Hansson <hansson@google.com>2018-02-27 20:20:15 +0000
commit4cb50c14b0e0015eda29efd56f84378b4c86e61e (patch)
treea21f89707cff9d009b1e1f95118bc983ec341413 /tests/UxRestrictionsSample
parent1eeadc44feee1c5a8bbd0367ee3dce9ef54b52e2 (diff)
downloadCar-4cb50c14b0e0015eda29efd56f84378b4c86e61e.tar.gz
packages/services/Car: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I1e77ed30aa2b67a6b8640a23fc42c28b0445bf29
Diffstat (limited to 'tests/UxRestrictionsSample')
-rw-r--r--tests/UxRestrictionsSample/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/UxRestrictionsSample/Android.mk b/tests/UxRestrictionsSample/Android.mk
index 283fb9bc81..2ed4258f7a 100644
--- a/tests/UxRestrictionsSample/Android.mk
+++ b/tests/UxRestrictionsSample/Android.mk
@@ -23,6 +23,7 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
LOCAL_PACKAGE_NAME := UxRestrictionsSample
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_MODULE_TAGS := optional