aboutsummaryrefslogtreecommitdiff
path: root/tests/vehiclehal_test
diff options
context:
space:
mode:
authorEnrico Granata <egranata@google.com>2017-02-21 14:29:03 -0800
committerEnrico Granata <egranata@google.com>2017-02-21 16:23:06 -0800
commit14b5d561eade5964288da907a4cf21b17dfd1381 (patch)
tree82dbc0ccfd25a5958f0955ce9bc9be9a15c55050 /tests/vehiclehal_test
parentd4a0b28d5b52b3098d828c51edf8d9dc8c5395e1 (diff)
downloadCar-14b5d561eade5964288da907a4cf21b17dfd1381.tar.gz
Post-O. Move OBD2 support to Vehicle HAL 2.1.
Test: build Change-Id: Ia1fd2e3057d3a4d35e6be00b7e5a11440027a575
Diffstat (limited to 'tests/vehiclehal_test')
-rw-r--r--tests/vehiclehal_test/Android.mk3
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java4
2 files changed, 4 insertions, 3 deletions
diff --git a/tests/vehiclehal_test/Android.mk b/tests/vehiclehal_test/Android.mk
index 5f7c57f7d3..56327bcc5e 100644
--- a/tests/vehiclehal_test/Android.mk
+++ b/tests/vehiclehal_test/Android.mk
@@ -33,7 +33,8 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES += vehicle-hal-support-lib \
android-support-test \
- android.hardware.automotive.vehicle@2.0-java-static
+ android.hardware.automotive.vehicle@2.0-java-static \
+ android.hardware.automotive.vehicle@2.1-java-static
LOCAL_JAVA_LIBRARIES := android.car android.test.runner
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java
index 5a9bd84416..4cdb403f17 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java
@@ -23,10 +23,10 @@ import static com.android.car.vehiclehal.test.Utils.tryWithDeadline;
import static org.junit.Assert.*;
import android.annotation.Nullable;
-import android.hardware.automotive.vehicle.V2_0.IVehicle;
import android.hardware.automotive.vehicle.V2_0.StatusCode;
import android.hardware.automotive.vehicle.V2_0.VehiclePropValue;
-import android.hardware.automotive.vehicle.V2_0.VehicleProperty;
+import android.hardware.automotive.vehicle.V2_1.IVehicle;
+import android.hardware.automotive.vehicle.V2_1.VehicleProperty;
import android.os.RemoteException;
import android.util.Log;
import java.util.Objects;