aboutsummaryrefslogtreecommitdiff
path: root/tests/vehiclehal_test
diff options
context:
space:
mode:
authorBrett Chabot <brettchabot@google.com>2018-12-13 19:06:42 -0800
committerBrett Chabot <brettchabot@google.com>2018-12-14 15:29:39 -0800
commita81f3e85b42953377aff3e4b26bfbc1a50902c33 (patch)
treed6041c52dc493dad099c165b6ad701db0df1dc41 /tests/vehiclehal_test
parentdc3675be2283f4820fed71285a1476ce4d0e4621 (diff)
downloadCar-a81f3e85b42953377aff3e4b26bfbc1a50902c33.tar.gz
Migrate packages/services/Car to androidx.test
See go/jetpack-test-android-migration Test: make checkbuild Change-Id: Ibc0ee624539f350051cfd0258286c6b7d316186d
Diffstat (limited to 'tests/vehiclehal_test')
-rw-r--r--tests/vehiclehal_test/Android.mk2
-rw-r--r--tests/vehiclehal_test/AndroidManifest.xml2
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarDiagnosticTest.java5
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarPropertyTest.java9
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2eCarTestBase.java4
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2ePerformanceTest.java9
6 files changed, 17 insertions, 14 deletions
diff --git a/tests/vehiclehal_test/Android.mk b/tests/vehiclehal_test/Android.mk
index d5adc65f37..58678b3ae6 100644
--- a/tests/vehiclehal_test/Android.mk
+++ b/tests/vehiclehal_test/Android.mk
@@ -33,7 +33,7 @@ LOCAL_MODULE_PATH := $(TARGET_OUT_DATA_APPS)
LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES += vehicle-hal-support-lib \
- android-support-test \
+ androidx.test.rules \
android.hidl.base-V1.0-java \
android.hardware.automotive.vehicle-V2.0-java
diff --git a/tests/vehiclehal_test/AndroidManifest.xml b/tests/vehiclehal_test/AndroidManifest.xml
index c03406dba7..ee0dccc650 100644
--- a/tests/vehiclehal_test/AndroidManifest.xml
+++ b/tests/vehiclehal_test/AndroidManifest.xml
@@ -20,7 +20,7 @@
<uses-permission android:name="android.car.permission.CONTROL_CAR_CLIMATE" />
- <instrumentation android:name="android.support.test.runner.AndroidJUnitRunner"
+ <instrumentation android:name="androidx.test.runner.AndroidJUnitRunner"
android:targetPackage="com.android.car.vehiclehal.test"
android:label="Tests for Vehicle HAL APIs"/>
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarDiagnosticTest.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarDiagnosticTest.java
index b0dd2c7dbc..c39683afc2 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarDiagnosticTest.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarDiagnosticTest.java
@@ -26,11 +26,12 @@ import android.car.hardware.CarPropertyValue;
import android.car.hardware.CarSensorManager;
import android.hardware.automotive.vehicle.V2_0.VehiclePropValue;
import android.hardware.automotive.vehicle.V2_0.VehicleProperty;
-import android.support.test.filters.LargeTest;
-import android.support.test.runner.AndroidJUnit4;
import android.util.Log;
import android.util.SparseIntArray;
+import androidx.test.filters.LargeTest;
+import androidx.test.runner.AndroidJUnit4;
+
import com.android.car.vehiclehal.VehiclePropValueBuilder;
import org.junit.Test;
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarPropertyTest.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarPropertyTest.java
index 27579bd540..e47c733464 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarPropertyTest.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/CarPropertyTest.java
@@ -18,21 +18,22 @@ package com.android.car.vehiclehal.test;
import static org.junit.Assert.assertNotNull;
import static org.junit.Assert.assertTrue;
-import static java.lang.Integer.toHexString;
-
import android.car.Car;
import android.car.hardware.CarPropertyConfig;
import android.car.hardware.CarPropertyValue;
import android.car.hardware.property.CarPropertyManager;
-import android.support.test.filters.LargeTest;
-import android.support.test.runner.AndroidJUnit4;
import android.util.ArraySet;
import android.util.Log;
+import androidx.test.filters.LargeTest;
+import androidx.test.runner.AndroidJUnit4;
+
import org.junit.Assert;
import org.junit.Test;
import org.junit.runner.RunWith;
+import static java.lang.Integer.toHexString;
+
import java.io.File;
import java.time.Duration;
import java.util.List;
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2eCarTestBase.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2eCarTestBase.java
index 9485d805e6..d78713fac7 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2eCarTestBase.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2eCarTestBase.java
@@ -28,9 +28,10 @@ import android.hardware.automotive.vehicle.V2_0.StatusCode;
import android.os.ConditionVariable;
import android.os.FileUtils;
import android.os.IBinder;
-import android.support.test.InstrumentationRegistry;
import android.util.Log;
+import androidx.test.InstrumentationRegistry;
+
import com.google.android.collect.Lists;
import org.json.JSONException;
@@ -44,7 +45,6 @@ import java.io.InputStream;
import java.io.OutputStream;
import java.util.List;
-
public class E2eCarTestBase {
private static final String TAG = Utils.concatTag(E2eCarTestBase.class);
private static final int DEFAULT_WAIT_TIMEOUT_MS = 1000;
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2ePerformanceTest.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2ePerformanceTest.java
index 6427a07233..d2f6669311 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2ePerformanceTest.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/E2ePerformanceTest.java
@@ -21,8 +21,6 @@ import static org.junit.Assert.assertNotNull;
import static org.junit.Assert.assertTrue;
import static org.junit.Assert.fail;
-import static java.lang.Integer.toHexString;
-
import android.annotation.Nullable;
import android.car.Car;
import android.car.CarNotConnectedException;
@@ -32,17 +30,20 @@ import android.car.hardware.CarSensorManager.OnSensorChangedListener;
import android.car.hardware.hvac.CarHvacManager;
import android.hardware.automotive.vehicle.V2_0.VehicleProperty;
import android.os.SystemClock;
-import android.support.test.filters.MediumTest;
-import android.support.test.runner.AndroidJUnit4;
import android.util.Log;
import android.util.SparseArray;
import android.util.SparseIntArray;
+import androidx.test.filters.MediumTest;
+import androidx.test.runner.AndroidJUnit4;
+
import com.google.android.collect.Lists;
import org.junit.Test;
import org.junit.runner.RunWith;
+import static java.lang.Integer.toHexString;
+
import java.util.ArrayList;
import java.util.List;
import java.util.concurrent.CountDownLatch;