aboutsummaryrefslogtreecommitdiff
path: root/tests/vehiclehal_test
diff options
context:
space:
mode:
authorSteven Moreland <smoreland@google.com>2017-08-02 10:20:36 -0700
committerSteven Moreland <smoreland@google.com>2017-08-02 19:44:03 +0000
commitbe4780ccce616f1ae9311eaf6967195360cb1e33 (patch)
tree46c7afb2e135795d441257c1584fdc41a4d30a89 /tests/vehiclehal_test
parent6660120112ac07bceccd9036877cb27ee1d94fff (diff)
downloadCar-be4780ccce616f1ae9311eaf6967195360cb1e33.tar.gz
Car: remove use of -static hidl java
These libraries are being removed. Now, the regular java library can be used as both a static and non-static library, we are removing these duplicate libraries which cause several types problems (such as undefined behavior when both the static and non-static libs are loaded). Bug: 36376126 Test: no build/runtime errors running test Change-Id: I7efb5d12d080c4c2006264b6fc119cf4292a5494
Diffstat (limited to 'tests/vehiclehal_test')
-rw-r--r--tests/vehiclehal_test/Android.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/vehiclehal_test/Android.mk b/tests/vehiclehal_test/Android.mk
index 43aa41f484..2c85c653c3 100644
--- a/tests/vehiclehal_test/Android.mk
+++ b/tests/vehiclehal_test/Android.mk
@@ -33,8 +33,8 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES += vehicle-hal-support-lib \
android-support-test \
- android.hardware.automotive.vehicle-V2.0-java-static \
- android.hardware.automotive.vehicle-V2.1-java-static
+ android.hardware.automotive.vehicle-V2.0-java \
+ android.hardware.automotive.vehicle-V2.1-java
LOCAL_JAVA_LIBRARIES := android.car android.test.runner