aboutsummaryrefslogtreecommitdiff
path: root/tests/vehiclehal_test
diff options
context:
space:
mode:
authorPavel Maltsev <pavelm@google.com>2017-02-02 12:38:08 -0800
committerPavel Maltsev <pavelm@google.com>2017-02-02 19:27:20 -0800
commitcfe93105f637c2822da113308f113ed418d0b319 (patch)
treed4e255ae4169ea7f29d10f444f65b38889399708 /tests/vehiclehal_test
parent2fb838823ed3783fd93de6bc7a3b8e27c03fcf46 (diff)
downloadCar-cfe93105f637c2822da113308f113ed418d0b319.tar.gz
Move Vehicle HAL under automotive package
Test: all existing tests passing Bug: b/33200203 Change-Id: Id1ff815ae2af9c48ce8612b4cfb5327de13a5a1f
Diffstat (limited to 'tests/vehiclehal_test')
-rw-r--r--tests/vehiclehal_test/Android.mk2
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java8
-rw-r--r--tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Utils.java6
3 files changed, 8 insertions, 8 deletions
diff --git a/tests/vehiclehal_test/Android.mk b/tests/vehiclehal_test/Android.mk
index 20dd3c7fda..5f7c57f7d3 100644
--- a/tests/vehiclehal_test/Android.mk
+++ b/tests/vehiclehal_test/Android.mk
@@ -33,7 +33,7 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES += vehicle-hal-support-lib \
android-support-test \
- android.hardware.vehicle@2.0-java-static
+ android.hardware.automotive.vehicle@2.0-java-static
LOCAL_JAVA_LIBRARIES := android.car android.test.runner
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java
index 7770cf89bf..5a9bd84416 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Obd2LiveFrameTest.java
@@ -23,10 +23,10 @@ import static com.android.car.vehiclehal.test.Utils.tryWithDeadline;
import static org.junit.Assert.*;
import android.annotation.Nullable;
-import android.hardware.vehicle.V2_0.IVehicle;
-import android.hardware.vehicle.V2_0.StatusCode;
-import android.hardware.vehicle.V2_0.VehiclePropValue;
-import android.hardware.vehicle.V2_0.VehicleProperty;
+import android.hardware.automotive.vehicle.V2_0.IVehicle;
+import android.hardware.automotive.vehicle.V2_0.StatusCode;
+import android.hardware.automotive.vehicle.V2_0.VehiclePropValue;
+import android.hardware.automotive.vehicle.V2_0.VehicleProperty;
import android.os.RemoteException;
import android.util.Log;
import java.util.Objects;
diff --git a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Utils.java b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Utils.java
index 3e79ce8472..c205fcc709 100644
--- a/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Utils.java
+++ b/tests/vehiclehal_test/src/com/android/car/vehiclehal/test/Utils.java
@@ -19,9 +19,9 @@ package com.android.car.vehiclehal.test;
import static android.os.SystemClock.elapsedRealtime;
import android.annotation.Nullable;
-import android.hardware.vehicle.V2_0.IVehicle;
-import android.hardware.vehicle.V2_0.VehiclePropConfig;
-import android.hardware.vehicle.V2_0.VehiclePropValue;
+import android.hardware.automotive.vehicle.V2_0.IVehicle;
+import android.hardware.automotive.vehicle.V2_0.VehiclePropConfig;
+import android.hardware.automotive.vehicle.V2_0.VehiclePropValue;
import android.os.RemoteException;
import android.util.Log;
import com.android.car.vehiclehal.VehiclePropValueBuilder;