summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-09 16:05:09 -0800
committerSasha Smundak <asmundak@google.com>2019-01-09 16:06:20 -0800
commitc8445fa587e7d38bc444707c0ea324a6c56d65d6 (patch)
treeeb0d9c38a9d25cf0284df3b7dc1b35fe47a12bdd
parentbf5d23fe7761ddc85b4d6ff8ee497c3bf83a1902 (diff)
downloadMms-c8445fa587e7d38bc444707c0ea324a6c56d65d6.tar.gz
Convert Android.mk file to Android.bp
See build/soong/README.md for more information. Change-Id: Idafc202a384d6d9f88a098b9e8f953769fbf2f92 Fixes: 122333681 Test: treehugger
-rw-r--r--Android.bp30
-rw-r--r--Android.mk38
2 files changed, 30 insertions, 38 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..0815d7c
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,30 @@
+// Copyright (C) 2014 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+//
+// Mms service
+//
+android_app {
+ name: "MmsService",
+ platform_apis: true,
+ privileged: true,
+ libs: ["telephony-common"],
+ srcs: ["src/**/*.java"],
+ resource_dirs: ["res"],
+ aaptflags: ["--auto-add-overlay"],
+ optimize: {
+ proguard_flags_files: ["proguard.flags"],
+ },
+ certificate: "platform",
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index b99c6b3..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (C) 2014 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-
-#
-# Mms service
-#
-include $(CLEAR_VARS)
-
-LOCAL_PACKAGE_NAME := MmsService
-LOCAL_PRIVATE_PLATFORM_APIS := true
-LOCAL_PRIVILEGED_MODULE := true
-
-LOCAL_JAVA_LIBRARIES := telephony-common
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-LOCAL_AAPT_FLAGS := --auto-add-overlay
-
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags
-
-LOCAL_CERTIFICATE := platform
-LOCAL_PRIVILEGED_MODULE := true
-
-include $(BUILD_PACKAGE)