aboutsummaryrefslogtreecommitdiff
path: root/rust/frontend/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/frontend/Cargo.toml')
-rw-r--r--rust/frontend/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/rust/frontend/Cargo.toml b/rust/frontend/Cargo.toml
new file mode 100644
index 00000000..9d5f308d
--- /dev/null
+++ b/rust/frontend/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "frontend"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+protobuf = "3.2.0"
+protoc-grpcio = "3.0.0"
+protoc-rust = "2.27"
+grpcio = "0.13.0"
+grpcio-sys = "0.12.1"
+futures = "0.3.26"
+
+##[build-dependencies]
+##protoc-grpcio = "3.0.0"
+
+##[[bin]]
+##name = "server"
+##path = "src/server.rs"
+
+##[[bin]]
+##name = "netsim-grpc"
+##path = "src/client.rs" \ No newline at end of file