aboutsummaryrefslogtreecommitdiff
path: root/clang/runtime/CMakeLists.txt
diff options
context:
space:
mode:
authorFilipe Cabecinhas <me@filcab.net>2016-03-01 14:08:13 +0000
committerFilipe Cabecinhas <me@filcab.net>2016-03-01 14:08:13 +0000
commit03ca68d6a6b46f5257d68efb83945efd22caf2bc (patch)
treecac500ebe0e945454cc5f28963d4b0a0dfdb2d70 /clang/runtime/CMakeLists.txt
parent0ddfde44ce3a414d123a4e4a8dd986da926d195b (diff)
downloadllvm-project-03ca68d6a6b46f5257d68efb83945efd22caf2bc.tar.gz
[cmake] Fallback to LLVM_EXTERNAL_COMPILER_RT_SOURCE_DIR if COMPILER_RT_SRC_ROOT doesn't exist.
llvm-svn: 262334
Diffstat (limited to 'clang/runtime/CMakeLists.txt')
-rw-r--r--clang/runtime/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/clang/runtime/CMakeLists.txt b/clang/runtime/CMakeLists.txt
index 3a3efa0bf72a..5c1d7deb2627 100644
--- a/clang/runtime/CMakeLists.txt
+++ b/clang/runtime/CMakeLists.txt
@@ -23,6 +23,13 @@ function(get_ext_project_build_command out_var target)
endfunction()
set(COMPILER_RT_SRC_ROOT ${LLVM_MAIN_SRC_DIR}/projects/compiler-rt)
+# Fallback to the external path, if the other one isn't available.
+# This is the same behavior (try "internal", then check the LLVM_EXTERNAL_...
+# variable) as in add_llvm_external_project
+if(NOT EXISTS ${COMPILER_RT_SRC_ROOT})
+ set(COMPILER_RT_SRC_ROOT ${LLVM_EXTERNAL_COMPILER_RT_SOURCE_DIR})
+endif()
+
if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
if(CMAKE_VERSION VERSION_GREATER 3.3.20150708)
set(cmake_3_4_USES_TERMINAL_OPTIONS