aboutsummaryrefslogtreecommitdiff
path: root/clang/runtime/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2016-04-28 12:14:47 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2016-04-28 12:14:47 +0000
commit5556a5cf3b743992d13a5a2429749e88d5e73c8d (patch)
tree55f762b5bbb46276e2fab8238f9c30cdfc1731e8 /clang/runtime/CMakeLists.txt
parent801d9b0cc4dca8a5ce190ac51b0c412263e95d95 (diff)
downloadllvm-project-5556a5cf3b743992d13a5a2429749e88d5e73c8d.tar.gz
Revert r267784, r267824 and r267830.
It makes compiler-rt tests fail if the gold plugin is enabled. Revert "Rework interface for bitset-using features to use a notion of LTO visibility." Revert "Driver: only produce CFI -fvisibility= error when compiling." Revert "clang/test/CodeGenCXX/cfi-blacklist.cpp: Exclude ms targets. They would be non-cfi." llvm-svn: 267871
Diffstat (limited to 'clang/runtime/CMakeLists.txt')
-rw-r--r--clang/runtime/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/clang/runtime/CMakeLists.txt b/clang/runtime/CMakeLists.txt
index e72847cb53d0..6d10e71d7274 100644
--- a/clang/runtime/CMakeLists.txt
+++ b/clang/runtime/CMakeLists.txt
@@ -148,3 +148,16 @@ if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
VERBATIM)
endif()
endif()
+
+set(src "${CMAKE_CURRENT_SOURCE_DIR}/vtables_blacklist.txt")
+set(dst "${LLVM_LIBRARY_OUTPUT_INTDIR}/clang/${CLANG_VERSION}/vtables_blacklist.txt")
+add_custom_command(OUTPUT ${dst}
+ DEPENDS ${src}
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different ${src} ${dst}
+ COMMENT "Copying vtables blacklist")
+add_custom_target(vtables_blacklist DEPENDS ${dst})
+set_target_properties(vtables_blacklist PROPERTIES FOLDER "Misc")
+if(TARGET clang)
+ add_dependencies(clang vtables_blacklist)
+endif()
+install(FILES ${src} DESTINATION lib${LLVM_LIBDIR_SUFFIX}/clang/${CLANG_VERSION})