aboutsummaryrefslogtreecommitdiff
path: root/clang/runtime/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-11-11 21:53:08 +0000
committerChris Bieneman <beanz@apple.com>2015-11-11 21:53:08 +0000
commit74d20e485308086b8f104da68e199e12256f36fc (patch)
treef1a7c8417b73432edfdb69af8af72c4f5449b083 /clang/runtime/CMakeLists.txt
parent66c126a042a382b8ea4a138cfd9321ad4a7c173f (diff)
downloadllvm-project-74d20e485308086b8f104da68e199e12256f36fc.tar.gz
[CMake] Fixing passthrough for variables starting with COMPILER_RT
This allows COMPILER_RT_* variables to be passed from the top-level CMake into the external project when LLVM_BUILD_EXTERNAL_COMPILER_RT=On. llvm-svn: 252809
Diffstat (limited to 'clang/runtime/CMakeLists.txt')
-rw-r--r--clang/runtime/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/clang/runtime/CMakeLists.txt b/clang/runtime/CMakeLists.txt
index 1a015f05f9af..ebbe152be1d9 100644
--- a/clang/runtime/CMakeLists.txt
+++ b/clang/runtime/CMakeLists.txt
@@ -48,7 +48,7 @@ if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
# them.
get_cmake_property(variableNames VARIABLES)
foreach(varaibleName ${variableNames})
- if(${varaibleName} MATCHES "^COMPILER_RT")
+ if(varaibleName MATCHES "^COMPILER_RT")
list(APPEND COMPILER_RT_PASSTHROUGH_VARIABLES
-D${varaibleName}=${${varaibleName}})
endif()