summaryrefslogtreecommitdiff
path: root/overlay/frameworks/base/packages/overlays/pixel_6
diff options
context:
space:
mode:
Diffstat (limited to 'overlay/frameworks/base/packages/overlays/pixel_6')
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/Android.mk31
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/AndroidManifest.xml24
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/config.xml55
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/dimens.xml21
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/Android.mk31
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/AndroidManifest.xml24
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/config.xml45
-rw-r--r--overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/dimens.xml55
8 files changed, 286 insertions, 0 deletions
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/Android.mk b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/Android.mk
new file mode 100644
index 00000000..16d68bb5
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/Android.mk
@@ -0,0 +1,31 @@
+#
+# Copyright 2023, The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_RRO_THEME := EmulationPixel6
+
+LOCAL_PRODUCT_MODULE := true
+
+LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
+
+LOCAL_PACKAGE_NAME := EmulationPixel6Overlay
+LOCAL_SDK_VERSION := current
+
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
+include $(BUILD_RRO_PACKAGE)
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/AndroidManifest.xml b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/AndroidManifest.xml
new file mode 100644
index 00000000..ed01671e
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/AndroidManifest.xml
@@ -0,0 +1,24 @@
+<!--
+/**
+ * Copyright (c) 2023, The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+-->
+<manifest xmlns:android="http://schemas.android.com/apk/res/android"
+ package="com.android.internal.emulation.pixel_6"
+ android:versionCode="1"
+ android:versionName="1.0">
+ <overlay android:targetPackage="android" android:priority="1"/>
+ <application android:label="Filled" android:hasCode="false"/>
+</manifest>
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/config.xml b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/config.xml
new file mode 100644
index 00000000..1f706e3c
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/config.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+/*
+** Copyright 2023, The Android Open Source Project
+**
+** Licensed under the Apache License, Version 2.0 (the "License");
+** you may not use this file except in compliance with the License.
+** You may obtain a copy of the License at
+**
+** http://www.apache.org/licenses/LICENSE-2.0
+**
+** Unless required by applicable law or agreed to in writing, software
+** distributed under the License is distributed on an "AS IS" BASIS,
+** WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+** See the License for the specific language governing permissions and
+** limitations under the License.
+*/
+-->
+
+<resources xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
+ <!-- Whether the display cutout region of the main built-in display should be forced to
+ black in software (to avoid aliasing or emulate a cutout that is not physically existent).
+ -->
+ <bool name="config_fillMainBuiltInDisplayCutout">true</bool>
+
+ <!-- Display cutout configuration -->
+ <string translatable="false" name="config_mainBuiltInDisplayCutout">
+ M 507,64
+ a 33,33 0 1 0 66,0 33,33 0 1 0 -66,0
+ Z
+ @left
+ </string>
+
+ <string translatable="false" name="config_mainBuiltInDisplayCutoutRectApproximation">
+ M 492,0
+ h 118
+ v 128
+ h -118
+ Z
+ @left
+ </string>
+
+ <!-- Radius of the software rounded corners. -->
+ <dimen name="rounded_corner_radius">28px</dimen>
+
+ <!-- Height of the status bar.
+ Do not read this dimen directly. Use {@link SystemBarUtils#getStatusBarHeight} instead.
+ -->
+ <dimen name="status_bar_height_height_default">74px</dimen>
+ <dimen name="status_bar_height_portrait">128px</dimen>
+ <dimen name="status_bar_height_landscape">74px</dimen>
+
+ <!-- Adjustment for software rounded corners since corners aren't perfectly round. -->
+ <dimen name="rounded_corner_radius_adjustment">5px</dimen>
+</resources>
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/dimens.xml b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/dimens.xml
new file mode 100644
index 00000000..8110ae84
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/AndroidOverlay/res/values/dimens.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+ * Copyright (c) 2023, The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+*/
+-->
+<resources>
+ <!-- for 20dp of padding at 3.5px/dp at default density -->
+ <dimen name="rounded_corner_content_padding">50px</dimen>
+</resources>
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/Android.mk b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/Android.mk
new file mode 100644
index 00000000..6b56927d
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/Android.mk
@@ -0,0 +1,31 @@
+#
+# Copyright 2023, The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_RRO_THEME := SystemUIEmulationPixel6
+
+LOCAL_PRODUCT_MODULE := true
+
+LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
+
+LOCAL_PACKAGE_NAME := SystemUIEmulationPixel6Overlay
+LOCAL_SDK_VERSION := current
+
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
+include $(BUILD_RRO_PACKAGE)
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/AndroidManifest.xml b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/AndroidManifest.xml
new file mode 100644
index 00000000..2d72ec75
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/AndroidManifest.xml
@@ -0,0 +1,24 @@
+<!--
+/**
+ * Copyright (c) 2023, The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+-->
+<manifest xmlns:android="http://schemas.android.com/apk/res/android"
+ package="com.android.systemui.emulation.pixel_6"
+ android:versionCode="1"
+ android:versionName="1.0">
+ <overlay android:targetPackage="com.android.systemui" android:priority="1"/>
+ <application android:label="Filled" android:hasCode="false"/>
+</manifest>
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/config.xml b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/config.xml
new file mode 100644
index 00000000..7c0b71b1
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/config.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+/*
+** Copyright 2023, The Android Open Source Project
+**
+** Licensed under the Apache License, Version 2.0 (the "License");
+** you may not use this file except in compliance with the License.
+** You may obtain a copy of the License at
+**
+** http://www.apache.org/licenses/LICENSE-2.0
+**
+** Unless required by applicable law or agreed to in writing, software
+** distributed under the License is distributed on an "AS IS" BASIS,
+** WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+** See the License for the specific language governing permissions and
+** limitations under the License.
+*/
+-->
+
+<!-- These resources are around just to allow their values to be customized
+ for different hardware and product builds. -->
+<resources>
+ <!-- Default rounded corner curve (a Bezier). Must match (the curved path in) rounded.xml.
+ Note that while rounded.xml includes the entire path (including the horizontal and vertical
+ corner edges), this pulls out just the curve.
+ -->
+ <string name="config_rounded_mask" translatable="false">M 71,0 C 33,0 22,-1 10,10 -1,22 0,33 0,71</string>
+
+ <!-- Configure 13px of extra protection around the front-facing camera -->
+ <string translatable="false" name="config_frontBuiltInDisplayCutoutProtection">
+ M 494,65
+ a 46,46 0 1 0 92,0
+ a 46,46 0 1 0 -92,0
+ Z
+ </string>
+
+ <!-- Camera 1 is the front camera on barbet -->
+ <string translatable="false" name="config_protectedCameraId">1</string>
+
+ <!-- Comma-separated list of packages to exclude from camera protection. In our case,
+ ignore the gaze detection package -->
+ <string translatable="false" name="config_cameraProtectionExcludedPackages">com.google.android.as</string>
+
+ <bool name="config_enableDisplayCutoutProtection">true</bool>
+</resources>
diff --git a/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/dimens.xml b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/dimens.xml
new file mode 100644
index 00000000..25113744
--- /dev/null
+++ b/overlay/frameworks/base/packages/overlays/pixel_6/SystemUIOverlay/res/values/dimens.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+ * Copyright (c) 2023, The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+*/
+-->
+<resources>
+ <!-- Don't need the left side padding due to being inset from the cutout -->
+ <dimen name="status_bar_padding_start">0dp</dimen>
+
+ <!-- the padding on the top of the statusbar (usually 0) -->
+ <dimen name="status_bar_padding_top">1px</dimen>
+
+ <!-- Height of the status bar header bar when on Keyguard (match status_bar_height) -->
+ <dimen name="status_bar_header_height_keyguard">@*android:dimen/status_bar_height</dimen>
+
+ <!-- Padding for the system icons on the keyguard (when no multi user switch is showing).
+ The icons always have a 4dp padding in the container so we only need 26 extra px of padding
+ for the corners -->
+ <dimen name="system_icons_super_container_avatarless_margin_end">26px</dimen>
+
+ <!-- Margin on the right side of the system icon group on Keyguard. -->
+ <dimen name="system_icons_keyguard_padding_end">4.5dp</dimen>
+
+ <dimen name="keyguard_carrier_text_margin">0px</dimen>
+
+ <dimen name="config_rounded_mask_size">71px</dimen>
+ <dimen name="config_rounded_mask_size_top">71px</dimen>
+ <dimen name="config_rounded_mask_size_bottom">70px</dimen>
+
+ <!-- Location on the screen of the center of the physical power button. -->
+ <dimen name="physical_power_button_center_screen_location_y">650px</dimen>
+
+ <!-- Location on the screen of the center of the physical volume up/down buttons. -->
+ <dimen name="physical_volume_up_button_center_screen_location_y">950px</dimen>
+ <dimen name="physical_volume_down_button_center_screen_location_y">1110px</dimen>
+
+
+ <!-- Padding for the lock icon on the keyguard. In pixels - should not scale with display size. -->
+ <dimen name="lock_icon_padding">54px</dimen>
+
+ <!-- Offset should not be more than 1mm -->
+ <dimen name="udfps_burn_in_offset_y">16px</dimen>
+</resources>