summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnie Reynoso <arnier@ti.com>2013-02-19 10:20:15 -0800
committerChris Ring <cring@ti.com>2013-02-23 12:20:12 -0800
commit54fa164e681c60a356a108118f22fea32773ccb7 (patch)
tree3669be0708e5c7e2de066b109c856986480af3e1 /Makefile.am
downloadipc-54fa164e681c60a356a108118f22fea32773ccb7.tar.gz
Initial commit
These sources roughly match the 'ipc-j09' tag from the previously internal development repo.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..70aae16
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+# the subdirectories of the project to go into
+SUBDIRS = linux/etc linux/src/utils linux/src/api linux/src/family linux/src/daemon linux/src/tests
+
+# hook to remove libtools library extention files (.la)
+install-exec-hook:
+ rm -f $(DESTDIR)$(libdir)/*.la
+
+# where to install common headers on the system
+ipcincludedir = $(includedir)/ti/ipc
+
+# the list of common header files (to be installed later)
+ipcinclude_HEADERS = $(top_srcdir)/packages/ti/ipc/MessageQ.h \
+ $(top_srcdir)/packages/ti/ipc/MultiProc.h \
+ $(top_srcdir)/packages/ti/ipc/NameServer.h
+