summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5eb9bd8ea..40df39324 100644
--- a/configure.ac
+++ b/configure.ac
@@ -469,12 +469,10 @@ AC_ARG_WITH([pkgconfigdir], AS_HELP_STRING([--with-pkgconfigdir=DIR],
AC_SUBST([pkgconfigdir])
#
-# Enable support for threads
-#
-# Find Posix threads library
+# Enable support for POSIX thread APIs
#
AC_ARG_WITH([threads],
- [AC_HELP_STRING([--without-threads], [disable threads support])],
+ [AC_HELP_STRING([--without-threads], [disable POSIX threads API support])],
[with_threads=$withval],
[with_threads='yes'])
@@ -487,7 +485,7 @@ if test "$with_threads" != 'no'; then
DEF_THREAD="$PTHREAD_CFLAGS"
CFLAGS="$CFLAGS $DEF_THREAD"
CXXFLAGS="$CXXFLAGS $DEF_THREAD"
- THREAD_LIBS="$PTHREAD_LIBS"
+ THREAD_LIBS="$PTHREAD_LIBS"
if test "$CC" != "$PTHREAD_CC"; then
AC_MSG_WARN([Replacing compiler $CC with compiler $PTHREAD_CC to support pthreads.])
CC="$PTHREAD_CC"