aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorClaudio Takahasi <claudio.takahasi@openbossa.org>2010-07-14 15:48:09 -0300
committerJohan Hedberg <johan.hedberg@nokia.com>2010-08-09 18:06:44 -0400
commitfcc6c7788e864ea44ba3c83b4595fc7102fcfce7 (patch)
tree11226d45fbbaf525a81349e08f92afacc08c2228 /Makefile.am
parentb4ad35aafe32a65e1796bb64631732593f8ae914 (diff)
downloadbluez-fcc6c7788e864ea44ba3c83b4595fc7102fcfce7.tar.gz
Initial GAttrib functions
GAttrib aims to provide high level functions to hide GATT/ATT internals. GATT client and server shall use these functions to serialize ATT requests/responses.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 00875475..c3534217 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,8 @@ sbc_sbcdec_LDADD = sbc/libsbc.la
sbc_sbcenc_SOURCES = sbc/sbcenc.c sbc/formats.h
sbc_sbcenc_LDADD = sbc/libsbc.la
+attrib_sources = attrib/att.h attrib/att.c attrib/gattrib.h attrib/gattrib.c
+
if SNDFILE
noinst_PROGRAMS += sbc/sbctester
@@ -170,7 +172,8 @@ endif
if ATTRIBPLUGIN
builtin_modules += attrib
-builtin_sources += attrib/main.c attrib/manager.h attrib/manager.c \
+builtin_sources += $(attrib_sources) attrib/main.c \
+ attrib/manager.h attrib/manager.c \
attrib/client.h attrib/client.c \
attrib/example.h attrib/example.c
endif