aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-06-03 12:44:58 +0000
committerMarcel Holtmann <marcel@holtmann.org>2008-06-03 12:44:58 +0000
commite0a54a416a5abc3bab139e5db6391c1926855ff6 (patch)
tree7e10e67da41a5cf28d0084277e91ad917a1fe8cb /test/Makefile.am
parentd2a60bd49635c5fabd3df4f406ae67fbad535d30 (diff)
downloadbluez-e0a54a416a5abc3bab139e5db6391c1926855ff6.tar.gz
Move passkey-agent and auth-agent sample code to test directory
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c2a456d5..16b80e7d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -4,7 +4,8 @@ sbin_PROGRAMS = hciemu
bin_PROGRAMS = l2test rctest
-noinst_PROGRAMS = sdptest scotest attest hstest bdaddr lmptest
+noinst_PROGRAMS = sdptest scotest attest hstest bdaddr lmptest \
+ passkey-agent auth-agent
hciemu_LDADD = $(top_builddir)/common/libhelper.a \
@GLIB_LIBS@ @BLUEZ_LIBS@
@@ -27,9 +28,13 @@ bdaddr_LDADD = @BLUEZ_LIBS@ $(top_builddir)/common/libhelper.a
lmptest_LDADD = @BLUEZ_LIBS@
+passkey_agent_LDADD = @DBUS_LIBS@
+
+auth_agent_LDADD = @DBUS_LIBS@
+
noinst_MANS = bdaddr.8
-AM_CFLAGS = @BLUEZ_CFLAGS@ @GLIB_CFLAGS@
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
endif
INCLUDES = -I$(top_srcdir)/common