summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2008-12-08 04:27:37 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2008-12-08 04:27:37 +0000
commit154fe24134aeb9f3a1d52890c64d227356bcbb43 (patch)
tree234516d1c218424db0fec6645fc9f10cfdf2660a /configure.in
parentbb63c612bfd9ba0dd2ae0e1f30b08e2cc7d50cf9 (diff)
downloadglib-154fe24134aeb9f3a1d52890c64d227356bcbb43.tar.gz
Add an implementation for the CRIS and CRISv32 architectures, by Peter
* configure.in: * glib/gatomic.c: Add an implementation for the CRIS and CRISv32 architectures, by Peter Kjellerstedt svn path=/trunk/; revision=7732
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7fab97f6b..f918ea050 100644
--- a/configure.in
+++ b/configure.in
@@ -2404,6 +2404,18 @@ if test x"$GCC" = xyes; then
[arm atomic implementation])
glib_memory_barrier_needed=no
;;
+ crisv32*|etraxfs*)
+ AC_MSG_RESULT([crisv32])
+ AC_DEFINE_UNQUOTED(G_ATOMIC_CRISV32, 1,
+ [crisv32 atomic implementation])
+ glib_memory_barrier_needed=no
+ ;;
+ cris*|etrax*)
+ AC_MSG_RESULT([cris])
+ AC_DEFINE_UNQUOTED(G_ATOMIC_CRIS, 1,
+ [cris atomic implementation])
+ glib_memory_barrier_needed=no
+ ;;
*)
AC_MSG_RESULT([none])
glib_memory_barrier_needed=yes