summaryrefslogtreecommitdiff
path: root/src/crypto/fipsmodule/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/fipsmodule/CMakeLists.txt')
-rw-r--r--src/crypto/fipsmodule/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/crypto/fipsmodule/CMakeLists.txt b/src/crypto/fipsmodule/CMakeLists.txt
index b99ebc71..a04ef6aa 100644
--- a/src/crypto/fipsmodule/CMakeLists.txt
+++ b/src/crypto/fipsmodule/CMakeLists.txt
@@ -202,19 +202,11 @@ if(FIPS_DELOCATE)
set_target_properties(bcm_hashunset PROPERTIES POSITION_INDEPENDENT_CODE ON)
set_target_properties(bcm_hashunset PROPERTIES LINKER_LANGUAGE C)
- set(MAYBE_INJECT_HASH_SHA256_FLAG "")
- # If building with OPENSSL_NO_ASM then ARCH will be "generic", but we still
- # need to use SHA-256. Since this only matters for FIPS, we only need to
- # worry about the Linux spelling of AArch64.
- if (ARCH STREQUAL "aarch64" OR CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
- set(MAYBE_INJECT_HASH_SHA256_FLAG "-sha256")
- endif()
-
go_executable(inject_hash
boringssl.googlesource.com/boringssl/util/fipstools/inject_hash)
add_custom_command(
OUTPUT bcm.o
- COMMAND ./inject_hash -o bcm.o -in-archive $<TARGET_FILE:bcm_hashunset> ${MAYBE_INJECT_HASH_SHA256_FLAG}
+ COMMAND ./inject_hash -o bcm.o -in-archive $<TARGET_FILE:bcm_hashunset>
DEPENDS bcm_hashunset inject_hash
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)