aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1491db3..25626ec 100644
--- a/setup.py
+++ b/setup.py
@@ -142,7 +142,7 @@ DESCRIPTION = 'Python bindings for the Brotli compression library'
AUTHOR = 'The Brotli Authors'
-LICENSE = 'Apache 2.0'
+LICENSE = 'MIT'
PLATFORMS = ['Posix', 'MacOS X', 'Windows']
@@ -150,7 +150,7 @@ CLASSIFIERS = [
'Development Status :: 4 - Beta',
'Environment :: Console',
'Intended Audience :: Developers',
- 'License :: OSI Approved :: Apache Software License',
+ 'License :: OSI Approved :: MIT License',
'Operating System :: MacOS :: MacOS X',
'Operating System :: Microsoft :: Windows',
'Operating System :: POSIX :: Linux',
@@ -181,7 +181,10 @@ EXT_MODULES = [
'_brotli',
sources=[
'python/_brotli.cc',
+ 'c/common/constants.c',
+ 'c/common/context.c',
'c/common/dictionary.c',
+ 'c/common/platform.c',
'c/common/transform.c',
'c/dec/bit_reader.c',
'c/dec/decode.c',
@@ -193,12 +196,14 @@ EXT_MODULES = [
'c/enc/block_splitter.c',
'c/enc/brotli_bit_stream.c',
'c/enc/cluster.c',
+ 'c/enc/command.c',
'c/enc/compress_fragment.c',
'c/enc/compress_fragment_two_pass.c',
'c/enc/dictionary_hash.c',
'c/enc/encode.c',
'c/enc/encoder_dict.c',
'c/enc/entropy_encode.c',
+ 'c/enc/fast_log.c',
'c/enc/histogram.c',
'c/enc/literal_cost.c',
'c/enc/memory.c',