aboutsummaryrefslogtreecommitdiff
path: root/scripts/ceres-solver.spec
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/ceres-solver.spec')
-rw-r--r--scripts/ceres-solver.spec30
1 files changed, 23 insertions, 7 deletions
diff --git a/scripts/ceres-solver.spec b/scripts/ceres-solver.spec
index b3b6f0f..1e5c7c0 100644
--- a/scripts/ceres-solver.spec
+++ b/scripts/ceres-solver.spec
@@ -1,15 +1,15 @@
Name: ceres-solver
-Version: 1.7.0
+Version: 1.9.0
# Release candidate versions are messy. Give them a release of
# e.g. "0.1.0%{?dist}" for RC1 (and remember to adjust the Source0
# URL). Non-RC releases go back to incrementing integers starting at 1.
-Release: 0.3.0%{?dist}
+Release: 0.2.0%{?dist}
Summary: A non-linear least squares minimizer
Group: Development/Libraries
License: BSD
-URL: http://code.google.com/p/ceres-solver/
-Source0: http://%{name}.googlecode.com/files/%{name}-%{version}rc3.tar.gz
+URL: http://ceres-solver.org/
+Source0: http://%{name}.org/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%if (0%{?rhel} == 06)
@@ -35,16 +35,17 @@ Ceres Solver is a portable C++ library that allows for modeling and solving
large complicated nonlinear least squares problems. Features include:
- A friendly API: build your objective function one term at a time
- - Automatic differentiation
+ - Automatic and numeric differentiation
- Robust loss functions
- Local parameterizations
- Threaded Jacobian evaluators and linear solvers
- - Levenberg-Marquardt and Dogleg (Powell & Subspace) solvers
+ - Trust region solvers with non-monotonic steps (Levenberg-Marquardt and Dogleg (Powell & Subspace))
+ - Line search solvers (L-BFGS and Nonlinear CG)
- Dense QR and Cholesky factorization (using Eigen) for small problems
- Sparse Cholesky factorization (using SuiteSparse) for large sparse problems
- Specialized solvers for bundle adjustment problems in computer vision
- Iterative linear solvers for general sparse and bundle adjustment problems
- - Runs on Linux, Windows, Mac OS X and Android. An iOS port is underway
+ - Runs on Linux, Windows, Mac OS X, Android, and iOS
Notable use of Ceres Solver is for the image alignment in Google Maps and for
vehicle pose in Google Street View.
@@ -110,6 +111,21 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Mon May 27 2014 Sameer Agarwal <sameeragarwal@google.com> - 1.9.0-0.2.0
+- Bump version
+
+* Fri May 16 2014 Sameer Agarwal <sameeragarwal@google.com> - 1.9.0-0.1.0
+- Bump version
+
+* Tue Nov 12 2013 Sameer Agarwal <sameeragarwal@google.com> - 1.8.0-0.3.0
+- Bump version
+
+* Wed Nov 6 2013 Sameer Agarwal <sameeragarwal@google.com> - 1.8.0-0.2.0
+- Bump version
+
+* Thu Oct 31 2013 Sameer Agarwal <sameeragarwal@google.com> - 1.8.0-0.1.0
+- Bump version
+
* Thu Aug 29 2013 Taylor Braun-Jones <taylor@braun-jones.org> - 1.7.0-0.3.0
- Bump version