aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoropenvcdiff <openvcdiff@132ac840-3546-0410-a738-d3f8764196be>2008-10-23 23:43:46 +0000
committeropenvcdiff <openvcdiff@132ac840-3546-0410-a738-d3f8764196be>2008-10-23 23:43:46 +0000
commit83bbde0df33922d8dc6fa737cfb306d9caae13b1 (patch)
tree2c96aa0fe5333a36a9d7dc05a43d16b91e6d4487 /Makefile.am
parent28db8079f707ebdf43ce62cdfd96eb39c8f889e0 (diff)
downloadopen-vcdiff-83bbde0df33922d8dc6fa737cfb306d9caae13b1.tar.gz
Thu, 23 Oct 2008 09:03:56 -0700 Google Inc. <opensource@google.com>
* Issue #6: vcdiff crashes with zero-size dictionary * Add special cases for empty dictionary file in vcdiff_main.cc. * Issue #7: vcdiff incorrect binary I/O on Windows * Change stdin/stdout file type to binary in vcdiff_main.cc. * Issue #13: Add unit test for vcdiff command-line executable * Unit test vcdiff_test.bat added for Visual Studio testing of vcdiff.exe. Includes regression tests for issues #6 and #7. * Issue #15: open-vcdiff fails to compile on Fedora 9 * Apply patch sent by Daniel Kegel * Add header <string.h> to src/vcdiffengine.cc, which uses memcpy. * Remove const qualifier from integral return types to fix gcc 4.3.1 warning. * Add contributors' names to THANKS file. git-svn-id: http://open-vcdiff.googlecode.com/svn/trunk@21 132ac840-3546-0410-a738-d3f8764196be
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dfa4d55..1447661 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -211,8 +211,10 @@ EXTRA_DIST = $(check_SCRIPTS) \
packages/rpm/rpm.spec \
packages/deb.sh \
packages/deb \
+ testdata/empty_file.txt \
vsprojects/config.h \
vsprojects/stdint.h \
+ vsprojects/vcdiff_test.bat \
vsprojects/open-vcdiff.sln \
vsprojects/addrcache_test/addrcache_test.vcproj \
vsprojects/blockhash_test/blockhash_test.vcproj \
@@ -231,4 +233,5 @@ EXTRA_DIST = $(check_SCRIPTS) \
vsprojects/vcdenc/vcdenc.vcproj \
vsprojects/vcdiff/vcdiff.vcproj \
vsprojects/vcdiffengine_test/vcdiffengine_test.vcproj \
+ vsprojects/vcdiff_test/vcdiff_test.vcproj \
vsprojects/vcencoder_test/vcencoder_test.vcproj