aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-04-22 23:35:34 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-04-22 23:35:34 +0000
commit67305a03479ba5b281b1b096d1243deee636b429 (patch)
tree28638647b9ff2b20d5999c693febf3b365f26c71 /CMakeLists.txt
parent9f2549154b3d605f0eec2fb691c741e087b61e6f (diff)
downloadgtest-67305a03479ba5b281b1b096d1243deee636b429.tar.gz
Minor improvement to hermetic build support in the CMake script, by Vlad Losev.
git-svn-id: http://googletest.googlecode.com/svn/trunk@422 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7910b5d..159f072 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,9 +8,11 @@
# ctest. You can select which tests to run using 'ctest -R regex'.
# For more options, run 'ctest --help'.
-# For hermetic builds, we may need to tell CMake to use compiler in a
+# For hermetic builds, we may need to tell CMake to use toolchain in a
# specific location.
+string(REPLACE "\\" "/" CMAKE_RC_COMPILER "${CMAKE_RC_COMPILER}")
if (gtest_compiler)
+ string(REPLACE "\\" "/" gtest_compiler "${gtest_compiler}")
include(CMakeForceCompiler)
cmake_force_c_compiler("${gtest_compiler}" "")
cmake_force_cxx_compiler("${gtest_compiler}" "")