aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorshiqian <shiqian@861a406c-534a-0410-8894-cb66d6ee9925>2008-11-24 20:13:22 +0000
committershiqian <shiqian@861a406c-534a-0410-8894-cb66d6ee9925>2008-11-24 20:13:22 +0000
commitfe6a9a48c2a8280439e58c2e9020268a80df89b3 (patch)
tree6d5be5dd4644d4c83cc5e434de31a8a4a59a3865 /configure.ac
parentc436e9f942ebd9cc6c2a93b840e1200100e2a66b (diff)
downloadgtest-fe6a9a48c2a8280439e58c2e9020268a80df89b3.tar.gz
Enables the Python tests to run with 2.3 (necessary for testing on Mac OS X Tiger); also fixes gtest_output_test when built with xcode.
git-svn-id: http://googletest.googlecode.com/svn/trunk@136 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9a61217..e19bbef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,13 +29,13 @@ AC_PROG_LIBTOOL
# TODO(chandlerc@google.com): Currently we aren't running the Python tests
# against the interpreter detected by AM_PATH_PYTHON, and so we condition
# HAVE_PYTHON by requiring "python" to be in the PATH, and that interpreter's
-# version to be >= 2.4. This will allow the scripts to use a "/usr/bin/env"
+# version to be >= 2.3. This will allow the scripts to use a "/usr/bin/env"
# hashbang.
-#AM_PATH_PYTHON([2.4],,[:])
+#AM_PATH_PYTHON([2.3],,[:])
PYTHON= # We *do not* allow the user to specify a python interpreter
AC_PATH_PROG([PYTHON],[python],[:])
AS_IF([test "$PYTHON" != ":"],
- [AM_PYTHON_CHECK_VERSION([$PYTHON],[2.4],[:],[PYTHON=":"])])
+ [AM_PYTHON_CHECK_VERSION([$PYTHON],[2.3],[:],[PYTHON=":"])])
AM_CONDITIONAL([HAVE_PYTHON],[test "$PYTHON" != ":"])
# TODO(chandlerc@google.com) Check for the necessary system headers.