aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Verkamp <dverkamp@chromium.org>2023-09-15 14:50:51 -0700
committercrosvm LUCI <crosvm-scoped@luci-project-accounts.iam.gserviceaccount.com>2023-10-02 23:28:45 +0000
commite10df59fd31158d882582d49d47900a11bc0b9da (patch)
tree37b37f711a8a4fa7e12905f0b48c324893715fa2 /Cargo.toml
parentd2e7bc77c65e22c68f66bf7cf573d9c6c4ab0f00 (diff)
downloadcrosvm-e10df59fd31158d882582d49d47900a11bc0b9da.tar.gz
devices: remove --software-tpm support
The software TPM backed by the libtpm2 simulator was only used for testing; now that we have the vTPM proxy device, the software TPM is no longer needed. This also allows removal of the tpm2 submodule (tpm2-sys/libtpm2). BUG=b:300673042 TEST=tools/dev_container tools/presubmit Change-Id: I3feb5f715f9f12f832450df712c0f63ed7b4fb13 Reviewed-on: https://chromium-review.googlesource.com/c/crosvm/crosvm/+/4875221 Reviewed-by: Dennis Kempin <denniskempin@google.com> Commit-Queue: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 0 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a30acd612..e083ad524 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -80,8 +80,6 @@ members = [
"system_api",
"third_party/vmm_vhost",
"tools/impl/catapult_converter",
- "tpm2-sys",
- "tpm2",
"usb_sys",
"usb_util",
"vendor/generic/anti_tamper",
@@ -169,10 +167,6 @@ swap = ["aarch64/swap", "arch/swap", "devices/swap", "vm_control/swap", "x86_64/
## Enables collection of VM statistics.
stats = ["devices/stats"]
-## Enables trusted platform module emulation for the guest. This relies on the software emulated
-## TPM implementation from libtpm2 which is suited only for testing purposes.
-tpm = ["devices/tpm"]
-
## Enables USB host device passthrough via an emulated XHCI controller.
## USB is supported only on unix/linux. The feature is a no-op on windows.
usb = ["devices/usb"]
@@ -332,7 +326,6 @@ all-default = [
"slirp",
"swap",
"trace_marker",
- "tpm",
"vaapi",
"video-decoder",
"video-encoder",
@@ -371,7 +364,6 @@ all-armhf = [
"gdb",
"libvda-stub",
"net",
- "tpm",
]
## All features that are compiled and tested for mingw64