aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAxel Lin <axel.lin@ingics.com>2013-12-30 18:19:02 +0800
committerMilan Broz <gmazyland@gmail.com>2014-01-01 21:13:09 +0100
commit3ba95a822f70ff1e8141230bc2830ae46346486b (patch)
tree373f6f8e48a0043f1445254abc4aa9b2419bc4a4 /configure.ac
parent486ec44c3e78b6ba337e4307975db673cbbf1fb1 (diff)
downloadcryptsetup-3ba95a822f70ff1e8141230bc2830ae46346486b.tar.gz
Link against -lrt for clock_gettime
Fix undefined reference to `clock_gettime' error. This is required since commit f3e398afc549 "Rewrite cipher benchmark loop.". Below is the build error report: http://autobuild.buildroot.net/results/9ca/9cad1cf49ee6b5c58d8260ee33beef2e6c1ada4d/build-end.log Signed-off-by: Axel Lin <axel.lin@ingics.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c456be..aa4c10f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,8 @@ AC_CHECK_LIB(uuid, uuid_clear, ,[AC_MSG_ERROR([You need the uuid library.])])
AC_SUBST(UUID_LIBS, $LIBS)
LIBS=$saved_LIBS
-AC_CHECK_FUNCS([posix_memalign])
+AC_SEARCH_LIBS([clock_gettime],[rt posix4])
+AC_CHECK_FUNCS([posix_memalign clock_gettime])
if test "x$enable_largefile" = "xno" ; then
AC_MSG_ERROR([Building with --disable-largefile is not supported, it can cause data corruption.])