aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dsinclair@google.com>2019-09-24 18:50:12 -0400
committerGitHub <noreply@github.com>2019-09-24 18:50:12 -0400
commit03ee97ca1492a4bf4f82df38f4f2a1899681fab0 (patch)
tree257109d867486b17edad7d95344e0a0db6f35f13 /src/CMakeLists.txt
parent289efa4b54b8c498c3623475558da89a2a715532 (diff)
downloadamber-03ee97ca1492a4bf4f82df38f4f2a1899681fab0.tar.gz
Remove DatumType usage from AmberScript parser. (#664)
This CL changes ToDatumType to be ToFormat and uses the generated format within the amber script parser. The DatumType class is moved into the vkscript/ folder as that is the only remaining usage.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 37e3528..b1c23e6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -18,7 +18,6 @@ set(AMBER_SOURCES
buffer.cc
command.cc
command_data.cc
- datum_type.cc
descriptor_set_and_binding_parser.cc
engine.cc
executor.cc
@@ -37,6 +36,7 @@ set(AMBER_SOURCES
value.cc
verifier.cc
vkscript/command_parser.cc
+ vkscript/datum_type.cc
vkscript/datum_type_parser.cc
vkscript/parser.cc
vkscript/section_parser.cc
@@ -133,7 +133,6 @@ if (${AMBER_ENABLE_TESTS})
amberscript/parser_test.cc
buffer_test.cc
command_data_test.cc
- datum_type_test.cc
descriptor_set_and_binding_parser_test.cc
executor_test.cc
format_parser_test.cc
@@ -145,6 +144,7 @@ if (${AMBER_ENABLE_TESTS})
tokenizer_test.cc
verifier_test.cc
vkscript/command_parser_test.cc
+ vkscript/datum_type_test.cc
vkscript/datum_type_parser_test.cc
vkscript/parser_test.cc
vkscript/section_parser_test.cc