aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2018-12-05 16:06:32 -0500
committerDavid Neto <dneto@google.com>2018-12-05 16:06:32 -0500
commit048ff06c36359edb8a1da872cc7549c56b772d61 (patch)
tree1a5dd4135242334ce62c3a3a1d34afb2d23395a0 /src/CMakeLists.txt
parent1f9a5cb320098c305b8052e66e8264a3d2c3fce5 (diff)
downloadamber-048ff06c36359edb8a1da872cc7549c56b772d61.tar.gz
Break apart Amber::Execute method. (#143)
Break apart Amber::Execute method. This CL splits Amber::Execute into a parse and execute step. The Parse step accepts a Recipe to fill out, that Recipe is then passed into the Execute step. The recipe, in the future, will allow retrieving information about the given script.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cd12b15..8b500f0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -27,6 +27,7 @@ set(AMBER_SOURCES
format.cc
parser.cc
pipeline_data.cc
+ recipe.cc
result.cc
sleep.cc
script.cc