aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoralan-baker <alanbaker@google.com>2019-07-23 08:32:36 -0400
committerGitHub <noreply@github.com>2019-07-23 08:32:36 -0400
commit1c7b905284129c4a9f2f735e08da6f53b4eb4d9b (patch)
tree860dfc404a066f9a37d6ca639afdebaea6a46359 /src/CMakeLists.txt
parentd7fc00b52faa239546eefd1e74f9fd2e3b25b993 (diff)
downloadamber-1c7b905284129c4a9f2f735e08da6f53b4eb4d9b.tar.gz
Opencl set for kernel args (#589)
Fixes #428 * Adds parsing (and tests) for SET command in pipeline command: * only for use with OPENCL-C shaders (errors out in other cases) ``` SET KERNEL ARG_NAME _name_ AS {datum_type} _value_ SET KERNEL ARG_NUMBER _number_ AS {datum_type} _value_ ``` * Executor now invokes the pipeline to generate buffers for the PoD args populated from SET commands * Allow clustered pod args * refactor opencl specific code in executor to its own loop * Add end-to-end test * Document SET command
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 03d183a..cdf5c47 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -123,6 +123,7 @@ if (${AMBER_ENABLE_TESTS})
amberscript/parser_extension_test.cc
amberscript/parser_framebuffer_test.cc
amberscript/parser_pipeline_test.cc
+ amberscript/parser_pipeline_set_test.cc
amberscript/parser_repeat_test.cc
amberscript/parser_run_test.cc
amberscript/parser_set_test.cc