aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2018-11-19 16:47:15 -0500
committerGitHub <noreply@github.com>2018-11-19 16:47:15 -0500
commit6296cc53f4608ee06fff0d57a6b266c541f0ca7a (patch)
tree91965332253d17eadc446857dd99794969cb32eb /src/CMakeLists.txt
parent016ef655f42c3d475d592150d759983beb2731ad (diff)
downloadamber-6296cc53f4608ee06fff0d57a6b266c541f0ca7a.tar.gz
Make the Buffer code common (#67)
This CL moves the AmberScript Buffer to be shared with VkScript. The Indices data is moved to be stored in a Buffer and passed as needed.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bad120e..bc1567a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -15,12 +15,12 @@
set(AMBER_SOURCES
amber.cc
amber_impl.cc
- amberscript/buffer.cc
amberscript/executor.cc
amberscript/parser.cc
amberscript/pipeline.cc
amberscript/script.cc
amberscript/shader.cc
+ buffer.cc
command.cc
command_data.cc
datum_type.cc
@@ -65,10 +65,10 @@ if (${Dawn_FOUND})
endif()
set(TEST_SRCS
- amberscript/buffer_test.cc
amberscript/parser_test.cc
amberscript/pipeline_test.cc
amberscript/script_test.cc
+ buffer_test.cc
command_data_test.cc
result_test.cc
shader_compiler_test.cc