aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-03-28 11:37:25 -0400
committerGitHub <noreply@github.com>2019-03-28 11:37:25 -0400
commit6fa4f59b6fa6f6abe5aca5447f853c582e9b4750 (patch)
treefd7369ad5ed1c3ddfffbfdd8d773c335ff6c2b81 /src/CMakeLists.txt
parent5fc7b6e796b9c6264e538a699ec3f50235a85449 (diff)
downloadamber-6fa4f59b6fa6f6abe5aca5447f853c582e9b4750.tar.gz
[amberscript] split parser test file (#432)
The parser test file is getting large and hard to work with. It's difficult to find what has been tested and where the tests are, along with causing merge conflicts. This CL splits the monolithic parser_test file into files based on what's being parsed.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 76c55a3..cad64da 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -75,6 +75,18 @@ endif()
if (${AMBER_ENABLE_TESTS})
set(TEST_SRCS
+ amberscript/parser_attach_test.cc
+ amberscript/parser_bind_test.cc
+ amberscript/parser_buffer_test.cc
+ amberscript/parser_clear_color_test.cc
+ amberscript/parser_clear_test.cc
+ amberscript/parser_copy_test.cc
+ amberscript/parser_expect_test.cc
+ amberscript/parser_framebuffer_test.cc
+ amberscript/parser_pipeline_test.cc
+ amberscript/parser_run_test.cc
+ amberscript/parser_shader_opt_test.cc
+ amberscript/parser_shader_test.cc
amberscript/parser_test.cc
buffer_test.cc
command_data_test.cc