aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-04-05 11:07:56 -0400
committerDavid Neto <dneto@google.com>2019-04-05 11:07:56 -0400
commita8acd2ec631cfafb3ea68c82524defca81a20547 (patch)
treec75b01aa6feab9e9811ccd91549b77b72fd632d9 /src/CMakeLists.txt
parentda78976bbc877e37fd7bd662621857fe15b297e5 (diff)
downloadamber-a8acd2ec631cfafb3ea68c82524defca81a20547.tar.gz
Generate a Format from a DataBuffer. (#448)
Generate a Format from a DataBuffer. When sending a VertexBuffer to Vulkan the data format is passed as a VkFormat string. When the buffer is provided in AmberScript it is not a FORMAT buffer. This CL adds the necessary code to generate a Format from a DatumType. This will allow creating the necessary format to send to Vulkan.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9906d07..5129739 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -94,6 +94,7 @@ if (${AMBER_ENABLE_TESTS})
amberscript/parser_test.cc
buffer_test.cc
command_data_test.cc
+ datum_type_test.cc
descriptor_set_and_binding_parser_test.cc
executor_test.cc
format_parser_test.cc