aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNeill Kapron <nkapron@google.com>2023-10-17 21:39:38 +0000
committerNeill Kapron <nkapron@google.com>2023-10-17 21:47:39 +0000
commit22a9c2dedab7722404b4055abc7559dd0bf37cf5 (patch)
tree7b9493e79c33e6ae4c03ab5eeb8ddb2b716f9a00 /CMakeLists.txt
parentea353ab8f68b23b5b5df9048beec26e3e3660680 (diff)
parent37e3bf08e0314efa08ba88600f07adf0079c987d (diff)
downloaddwarves-22a9c2dedab7722404b4055abc7559dd0bf37cf5.tar.gz
Merge remote-tracking branch 'aosp/upstream-master'
* aosp/upstream-master: (102 commits) pahole: Don't keep structs in multiple RB trees README: Remove old comments about ancient distros and add 'git submodule' instruction spec: Migrate license to a SPDX standardized one dwarf_loader: DW_TAG_subroutine_type may have a DW_AT_byte_size pdwtags: Print DW_TAG_constant tags fprintf: Add DW_TAG_constant pretty printer (constant__fprintf) dwarf_loader: Add support for DW_TAG_constant pahole: Prep 1.25 fprintf: Fix `*` not being printed for pointers with btf_type_tag btf_loader: A hack for BTF import of btf_type_tag attributes fprintf: Correct names for types with btf_type_tag attribute btf_encoder: Compare functions via prototypes not parameter names fprintf: Support skipping modifier fprintf: Generalize function prototype print to support passing conf dwarf_loader: Fix for BTF id drift caused by adding unspecified types fprintf: Support DW_TAG_LLVM_annotation in dwarf_tag_name() CMakeLists.txt: Call cmake_minimum_required() before project() dwarf_loader: Only mark parameter as using an unexpected register when it does dwarf_loader: Fix parameter location retrieval for location lists dwarf_loader: Fix detection of struct parameters ... Change-Id: I2acdff5dedb4df07f5fd2890db52fea90b1614c8 Signed-off-by: Neill Kapron <nkapron@google.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0363b8..98642e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-project(pahole C)
cmake_minimum_required(VERSION 2.8.12)
+project(pahole C)
cmake_policy(SET CMP0005 NEW)
option(LIBBPF_EMBEDDED "Use the embedded version of libbpf instead of searching it via pkg-config" ON)
@@ -54,9 +54,9 @@ if (NOT DEFINED BUILD_SHARED_LIBS)
endif (NOT DEFINED BUILD_SHARED_LIBS)
# Just for grepping, DWARVES_VERSION isn't used anywhere anymore
-# add_definitions(-D_GNU_SOURCE -DDWARVES_VERSION="v1.23")
+# add_definitions(-D_GNU_SOURCE -DDWARVES_VERSION="v1.25")
add_definitions(-D_GNU_SOURCE -DDWARVES_MAJOR_VERSION=1)
-add_definitions(-D_GNU_SOURCE -DDWARVES_MINOR_VERSION=23)
+add_definitions(-D_GNU_SOURCE -DDWARVES_MINOR_VERSION=25)
find_package(DWARF REQUIRED)
find_package(ZLIB REQUIRED)
find_package(argp REQUIRED)
@@ -149,7 +149,7 @@ target_link_libraries(dtagnames dwarves)
set(pahole_SRCS pahole.c)
add_executable(pahole ${pahole_SRCS})
-target_link_libraries(pahole dwarves dwarves_reorganize)
+target_link_libraries(pahole dwarves dwarves_emit dwarves_reorganize)
set(pdwtags_SRCS pdwtags.c)
add_executable(pdwtags ${pdwtags_SRCS})