aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2018-08-18 11:19:25 -0400
committerTheodore Ts'o <tytso@mit.edu>2018-08-18 11:21:30 -0400
commit0afb9be6aa326f69ecb3756f06aaaf1cb8150713 (patch)
treec00206edff6ef11c7b159a26b965cd1bf7e4b593 /configure.ac
parente5f0f3eebef7b483d5cc8b37023d6e0256776d94 (diff)
downloade2fsprogs-0afb9be6aa326f69ecb3756f06aaaf1cb8150713.tar.gz
Drop subset tarball and replace it with "configure --enable-subset"
There's no point creating two separate tarfiles. It's not clear anyone was actually using the subset tarball --- and if they are, they can replace it by the full source distribution and using the --enable-subset option. Signed-off-by: Theodore Ts'o <tytso@mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 81173d00..f365cfa6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -565,6 +565,21 @@ AC_SUBST(PROFILED_LIBBLKID)
AC_SUBST(DEPPROFILED_LIBBLKID)
AC_SUBST(BLKID_CMT)
dnl
+dnl handle --enable-subset
+dnl
+ALL_CMT=
+AC_ARG_ENABLE([subset],
+[ --enable-subset enable subset-only build],
+if test "$enableval" = "no"
+then
+ AC_MSG_RESULT([Disabling subset-only build])
+else
+ ALL_CMT=#
+ AC_MSG_RESULT([Enabling subset-only-build])
+fi
+,)
+AC_SUBST(ALL_CMT)
+dnl
dnl handle --disable-backtrace
dnl
AH_TEMPLATE([DISABLE_BACKTRACE], [Define to 1 to disable use of backtrace])