aboutsummaryrefslogtreecommitdiff
path: root/demos/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorNarayan Kamath <narayan@google.com>2012-11-02 10:59:05 +0000
committerXiaotao Duan <xiaotao@google.com>2012-11-07 14:17:48 -0800
commitc981c48f5bc9aefeffc0bcb0cc3934c2fae179dd (patch)
tree54d1c7d66098154c1d7c5bd414394ef4cf255810 /demos/opengl/CMakeLists.txt
parent63f67d748682b46d58be31235a0a2d64d81b998c (diff)
downloadeigen-kitkat-cts-release.tar.gz
Added a README.android and a MODULE_LICENSE_MPL2 file. Added empty Android.mk and CleanSpec.mk to optimize Android build. Non MPL2 license code is disabled in ./Eigen/src/Core/util/NonMPL2.h. Trying to include such files will lead to an error. Change-Id: I0e148b7c3e83999bcc4dfaa5809d33bfac2aac32
Diffstat (limited to 'demos/opengl/CMakeLists.txt')
-rw-r--r--demos/opengl/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/demos/opengl/CMakeLists.txt b/demos/opengl/CMakeLists.txt
new file mode 100644
index 000000000..b98a30c01
--- /dev/null
+++ b/demos/opengl/CMakeLists.txt
@@ -0,0 +1,20 @@
+find_package(Qt4 REQUIRED)
+find_package(OpenGL REQUIRED)
+
+set(QT_USE_QTOPENGL TRUE)
+include(${QT_USE_FILE})
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+include_directories( ${QT_INCLUDE_DIR} )
+
+set(quaternion_demo_SRCS gpuhelper.cpp icosphere.cpp camera.cpp trackball.cpp quaternion_demo.cpp)
+
+qt4_automoc(${quaternion_demo_SRCS})
+
+add_executable(quaternion_demo ${quaternion_demo_SRCS})
+add_dependencies(demos quaternion_demo)
+
+target_link_libraries(quaternion_demo
+ ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY}
+ ${QT_QTOPENGL_LIBRARY} ${OPENGL_LIBRARIES} )