aboutsummaryrefslogtreecommitdiff
path: root/unsupported/CMakeLists.txt
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2022-04-28 15:56:36 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2022-04-28 15:56:36 +0000
commitb06cbe0aaab4156d7796d06083b29f0029caacf9 (patch)
treefb979fb4cf4f8052c8cc66b1ec9516d91fcd859b /unsupported/CMakeLists.txt
parentebb9b35b8ba326e77933f1a8283f5f62decadf57 (diff)
parentbc0f5df265caa21a2120c22453655a7fcc941991 (diff)
downloadeigen-android13-frc-media-release.tar.gz
Snap for 8512216 from bc0f5df265caa21a2120c22453655a7fcc941991 to tm-frc-media-releaset_frc_med_330443030android13-frc-media-release
Change-Id: I3ce64ce71cedb6c72ed116ba550b07bc9d82743c
Diffstat (limited to 'unsupported/CMakeLists.txt')
-rw-r--r--unsupported/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/unsupported/CMakeLists.txt b/unsupported/CMakeLists.txt
index 4fef40a86..34408c017 100644
--- a/unsupported/CMakeLists.txt
+++ b/unsupported/CMakeLists.txt
@@ -1,7 +1,11 @@
add_subdirectory(Eigen)
-add_subdirectory(doc EXCLUDE_FROM_ALL)
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
-else()
- add_subdirectory(test EXCLUDE_FROM_ALL)
+if(EIGEN_BUILD_DOC)
+ add_subdirectory(doc EXCLUDE_FROM_ALL)
+endif()
+if(BUILD_TESTING)
+ if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+ else()
+ add_subdirectory(test EXCLUDE_FROM_ALL)
+ endif()
endif()