aboutsummaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index a66f5490..0d3ba164 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -40,9 +40,16 @@ pkgconfig_DATA += libdebuginfod.pc
install-data-local:
$(INSTALL_DATA) profile.sh -D $(DESTDIR)$(sysconfdir)/profile.d/debuginfod.sh
$(INSTALL_DATA) profile.csh -D $(DESTDIR)$(sysconfdir)/profile.d/debuginfod.csh
+ mkdir -p $(DESTDIR)$(sysconfdir)/debuginfod
+ if [ -n "@DEBUGINFOD_URLS@" ]; then \
+ echo "@DEBUGINFOD_URLS@" > $(DESTDIR)$(sysconfdir)/debuginfod/elfutils.urls; \
+ fi
uninstall-local:
- rm -f $(DESTDIR)$(sysconfdir)/profile.d/debuginfod.sh $(DESTDIR)$(sysconfdir)/profile.d/debuginfod.csh
+ rm -f $(DESTDIR)$(sysconfdir)/profile.d/debuginfod.sh
+ rm -f $(DESTDIR)$(sysconfdir)/profile.d/debuginfod.csh
+ rm -f $(DESTDIR)$(sysconfdir)/debuginfod/elfutils.urls
+ -rmdir $(DESTDIR)$(sysconfdir)/debuginfod
endif
if MAINTAINER_MODE