aboutsummaryrefslogtreecommitdiff
path: root/fuse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fuse/Makefile.am')
-rw-r--r--fuse/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/fuse/Makefile.am b/fuse/Makefile.am
index 0a78c0a..3179a2b 100644
--- a/fuse/Makefile.am
+++ b/fuse/Makefile.am
@@ -1,9 +1,10 @@
# SPDX-License-Identifier: GPL-2.0+
AUTOMAKE_OPTIONS = foreign
+noinst_HEADERS = $(top_srcdir)/fuse/macosx.h
bin_PROGRAMS = erofsfuse
erofsfuse_SOURCES = main.c
-erofsfuse_CFLAGS = -Wall -Werror -I$(top_srcdir)/include
+erofsfuse_CFLAGS = -Wall -I$(top_srcdir)/include
erofsfuse_CFLAGS += -DFUSE_USE_VERSION=26 ${libfuse_CFLAGS} ${libselinux_CFLAGS}
erofsfuse_LDADD = $(top_builddir)/lib/liberofs.la ${libfuse_LIBS} ${liblz4_LIBS} \
${libselinux_LIBS} ${liblzma_LIBS}