aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1341e9f3..3fac2afc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,7 +199,10 @@ if (HAVE_STRTOD_L)
endif ()
if (MINGW)
- target_compile_options(fmt PUBLIC "-Wa,-mbig-obj")
+ check_cxx_compiler_flag("Wa,-mbig-obj" FMT_HAS_MBIG_OBJ)
+ if (${FMT_HAS_MBIG_OBJ})
+ target_compile_options(fmt PUBLIC "-Wa,-mbig-obj")
+ endif()
endif ()
if (FMT_WERROR)